classification
Title: test_thread is flaky
Type: behavior Stage: resolved
Components: Library (Lib), Tests Versions: Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: pitrou Nosy List: ned.deily, pitrou
Priority: normal Keywords:

Created on 2009-10-23 18:20 by pitrou, last changed 2009-10-28 09:20 by ned.deily. This issue is now closed.

Messages (4)
msg94392 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-10-23 18:20
test_thread sometimes tries to release an unacquired mutex. It is easier
to reproduce when using the "-j" option (on trunk and py3k, since the
option doesn't exist on 2.6/3.1):

./python -m test.regrtest -j4 test_thread test_thread test_thread
test_thread
test_thread
test_thread
test_thread
Unhandled exception in thread started by <bound method
ThreadRunningTests.task of <test.test_thread.ThreadRunningTests
testMethod=test_stack_size>>
Traceback (most recent call last):
  File "/home/antoine/py3k/__svn__/Lib/test/test_thread.py", line 49, in
task
    self.done_mutex.release()
_thread.error: release unlocked lock
test_thread
msg94393 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-10-23 18:36
Fixed in trunk, py3k and 3.1. Waiting for 2.6 to unfreeze before merging
there.
msg94559 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-10-27 13:11
Backported to 2.6 in r75748.
msg94617 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2009-10-28 09:20
Duplicate of Issue6186?
History
Date User Action Args
2009-10-28 09:20:16ned.deilysetnosy: + ned.deily
messages: + msg94617
2009-10-27 13:11:19pitrousetstatus: open -> closed
resolution: accepted -> fixed
messages: + msg94559
2009-10-23 18:36:03pitrousetversions: - Python 3.1, Python 2.7, Python 3.2
messages: + msg94393

assignee: pitrou
resolution: accepted
stage: needs patch -> resolved
2009-10-23 18:20:45pitroucreate