classification
Title: socket.py: r75412 broke build
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_ssl failure
View: 7133
Assigned To: pitrou Nosy List: kbk, pitrou, r.david.murray
Priority: high Keywords:

Created on 2009-10-16 01:24 by kbk, last changed 2009-10-16 02:21 by kbk. This issue is now closed.

Messages (3)
msg94118 - (view) Author: Kurt B. Kaiser (kbk) * (Python committer) Date: 2009-10-16 01:24
buildbots failing since r75412:

testSocketServer (test.test_ssl.ThreadedTests) ... Traceback (most 
recent call last):
  File "/home/buildslave/python-trunk/trunk.norwitz-x86/build/Lib/
SocketServer.py", line 282, in _handle_request_noblock
    self.process_request(request, client_address)
  File "/home/buildslave/python-trunk/trunk.norwitz-x86/build/Lib/
SocketServer.py", line 308, in process_request
    self.finish_request(request, client_address)
  File "/home/buildslave/python-trunk/trunk.norwitz-x86/build/Lib/
SocketServer.py", line 321, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/home/buildslave/python-trunk/trunk.norwitz-x86/build/Lib/
SocketServer.py", line 639, in __init__
    self.finish()
  File "/home/buildslave/python-trunk/trunk.norwitz-x86/build/Lib/
SocketServer.py", line 692, in finish
    self.wfile.flush()
  File "/home/buildslave/python-trunk/trunk.norwitz-x86/build/Lib/
socket.py", line 300, in flush
    self._sock.sendall(view[write_offset:write_offset+buffer_size])
  File "/home/buildslave/python-trunk/trunk.norwitz-x86/build/Lib/
ssl.py", line 203, in sendall
    v = self.send(data[count:])
  File "/home/buildslave/python-trunk/trunk.norwitz-x86/build/Lib/
ssl.py", line 94, in <lambda>
    self.send = lambda data, flags=0: SSLSocket.send(self, data, flags)
  File "/home/buildslave/python-trunk/trunk.norwitz-x86/build/Lib/
ssl.py", line 174, in send
    v = self._sslobj.write(data)
TypeError: must be string or read-only buffer, not memoryview
msg94119 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-10-16 01:33
This is a duplicate of issue 7133, where Antoine has already proposed a
patch.
msg94121 - (view) Author: Kurt B. Kaiser (kbk) * (Python committer) Date: 2009-10-16 02:20
bah.  I looked twice for a prior bug and missed it!  Sorry....
History
Date User Action Args
2009-10-16 02:21:00kbksetmessages: + msg94121
2009-10-16 01:33:45r.david.murraysetstatus: open -> closed

superseder: test_ssl failure

nosy: + r.david.murray
messages: + msg94119
resolution: duplicate
stage: resolved
2009-10-16 01:24:20kbkcreate