classification
Title: test_telnetlib gives spurious output
Type: behavior Stage:
Components: Tests Versions: Python 3.1, Python 3.2, Python 2.7
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, jackdied, orsenthil, pitrou
Priority: normal Keywords:

Created on 2009-09-21 21:34 by pitrou, last changed 2010-07-15 01:39 by jackdied. This issue is now closed.

Messages (5)
msg92962 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-09-21 21:34
I just got the following traceback:

Exception in thread Thread-538:
Traceback (most recent call last):
  File "/home/antoine/py3k/__svn__/Lib/threading.py", line 509, in
_bootstrap_inner
    self.run()
  File "/home/antoine/py3k/__svn__/Lib/threading.py", line 462, in run
    self._target(*self._args, **self._kwargs)
  File "/home/antoine/py3k/__svn__/Lib/test/test_telnetlib.py", line 25,
in server
    conn, addr = serv.accept()
  File "/home/antoine/py3k/__svn__/Lib/socket.py", line 120, in accept
    fd, addr = self._accept()
socket.error: [Errno 4] Interrupted system call


Interestingly, it happens *after* test_telnetlib returned successfully.
msg109977 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-07-11 09:42
Is this reproducible or can this be closed?
msg110319 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2010-07-14 19:36
No problems observed now. I randomized and ran the tests a couple of times. I don't know what the scenario was when this was observed, so I will let __ap__ close the issue.
msg110320 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-07-14 19:37
Ok, let's say this was an exceptional failure.
msg110342 - (view) Author: Jack Diederich (jackdied) * (Python committer) Date: 2010-07-15 01:39
r76133 (which came after this bug) fixed most test_telnetlib bugs by using mocks instead of trying to setup full-blown client/server TCP cases.
History
Date User Action Args
2010-07-15 01:39:31jackdiedsetmessages: + msg110342
2010-07-14 19:37:57pitrousetstatus: open -> closed
resolution: works for me
messages: + msg110320
2010-07-14 19:36:59orsenthilsetnosy: + orsenthil
messages: + msg110319
2010-07-11 09:42:49BreamoreBoysetnosy: + BreamoreBoy

messages: + msg109977
versions: + Python 3.1, Python 2.7
2009-09-21 21:34:10pitroucreate