classification
Title: OS X IDLE has two Preferences menus on 2.6.x with Tk > 8.4.7
Type: behavior Stage: resolved
Components: IDLE, macOS Versions: Python 2.6
process
Status: closed Resolution: accepted
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: ned.deily, ronaldoussoren
Priority: critical Keywords: easy

Created on 2009-09-20 08:05 by ned.deily, last changed 2009-09-20 20:22 by ronaldoussoren. This issue is now closed.

Files
File name Uploaded Description Edit
patch-nad0027-26.txt ned.deily, 2009-09-20 08:05
Messages (2)
msg92883 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2009-09-20 08:05
Release blocker

On OS X IDLE 2.6 shows two Preference menu items, the second dimmed out, 
but only when running with an installed Tk 8.4 > 8.4.7.

This is the same problem identified in Issue6100 and was fixed in trunk 
but not backported.  Now that the Apple-supplied 8.4 Tk in 10.6 is 8.4.19, 
the problem is more serious on 2.6.  The attached patch backports r72946 
from trunk.
msg92910 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2009-09-20 19:07
I've svnmerge-d the patch in r74976.

BTW. Thanks for checking the various Tk releases on 10.5/10.6.
History
Date User Action Args
2009-09-20 20:22:44ronaldoussorensetstatus: open -> closed
type: behavior
resolution: accepted
stage: resolved
2009-09-20 19:07:54ronaldoussorensetmessages: + msg92910
2009-09-20 08:57:27georg.brandlsetpriority: critical
keywords: + easy
2009-09-20 08:05:15ned.deilycreate