classification
Title: A few tests are failing when zlib is not supported
Type: behavior Stage: resolved
Components: Tests Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_(zipfile|zipimport|gzip|distutils|sqlite) fail if zlib is not available
View: 6026
Assigned To: Nosy List: ezio.melotti, nicdumz, r.david.murray
Priority: normal Keywords:

Created on 2009-08-24 15:13 by nicdumz, last changed 2009-08-24 17:47 by ezio.melotti. This issue is now closed.

Messages (2)
msg91923 - (view) Author: Nicolas Dumazet (nicdumz) Date: 2009-08-24 15:13
test_distutils, test_zipfile, test_gzip and test_zimport are not
completely safe when zlib module is not available.

I've uploaded a patch on Rietveld which solves the issue here:
http://codereview.appspot.com/111041
Those are my first steps with Rietveld, please let me know if I can
improve something :)

Thanks,
Nicolas.
msg91924 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-08-24 15:56
This is a duplicate of issue 6026, where patch activity has already
occurred.  Thanks for working on this, and please review that case and
see if all of the issues you found are addressed there.
History
Date User Action Args
2009-08-24 17:47:12ezio.melottisetnosy: + ezio.melotti
2009-08-24 15:56:41r.david.murraysetstatus: open -> closed
priority: normal
superseder: test_(zipfile|zipimport|gzip|distutils|sqlite) fail if zlib is not available


nosy: + r.david.murray
messages: + msg91924
resolution: duplicate
stage: resolved
2009-08-24 15:13:43nicdumzcreate