classification
Title: Missing alias utf-8 in Standard Encodings list.
Type: Stage:
Components: Documentation Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: georg.brandl, lemburg, mintaka
Priority: normal Keywords:

Created on 2009-08-24 07:40 by mintaka, last changed 2009-08-24 17:15 by georg.brandl. This issue is now closed.

Messages (4)
msg91904 - (view) Author: Mintaka (mintaka) Date: 2009-08-24 07:40
On page 
http://docs.python.org/dev/3.0/library/codecs.html#standard-encodings
(and on the pages for older versions too)
in the table with review, is missing higly used alias "utf-8"

On that row is only:
Codec 	Aliases 	Languages
utf_8 	U8, UTF, utf8 	all languages
And probably there should be:
utf_8 	U8, UTF, utf8, utf-8 	all languages
msg91905 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2009-08-24 07:44
From the quoted page:

"""
Notice that spelling alternatives that only differ in case or use a
hyphen instead of an underscore are also valid aliases.
"""
msg91906 - (view) Author: Mintaka (mintaka) Date: 2009-08-24 07:55
True, but this one is much more used then others. So frequently, that
look like other names are aliases. Maybe it is good reason to mention it
explicitly.
msg91926 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2009-08-24 17:15
I made a compromise in r74545: 'utf-8' is now used as an example to
demonstrate the statement Marc-Andre cited.
History
Date User Action Args
2009-08-24 17:15:03georg.brandlsetmessages: + msg91926
2009-08-24 07:55:16mintakasetmessages: + msg91906
2009-08-24 07:44:11lemburgsetstatus: open -> closed

nosy: + lemburg
messages: + msg91905

resolution: not a bug
2009-08-24 07:40:38mintakacreate