classification
Title: -1**2=-1
Type: compile error Stage:
Components: 2to3 (2.x to 3.x conversion tool) Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, rahul1618
Priority: normal Keywords:

Created on 2009-08-21 08:58 by rahul1618, last changed 2009-08-21 09:09 by amaury.forgeotdarc. This issue is now closed.

Messages (3)
msg91809 - (view) Author: rahul (rahul1618) Date: 2009-08-21 08:58
what is the reason for this ????
msg91810 - (view) Author: rahul (rahul1618) Date: 2009-08-21 09:00
>>>-1**2
>>>-1 

???

what is reason for this
msg91811 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-08-21 09:09
This very example is in the documentation:
http://docs.python.org/reference/expressions.html#the-power-operator
History
Date User Action Args
2009-08-21 09:09:02amaury.forgeotdarcsetstatus: open -> closed

nosy: + amaury.forgeotdarc
messages: + msg91811

resolution: not a bug
2009-08-21 09:00:21rahul1618setmessages: + msg91810
2009-08-21 08:58:56rahul1618create