classification
Title: pyuic4.bat has bad path to python.exe and pyuic.py
Type: Stage:
Components: Demos and Tools Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, maar
Priority: normal Keywords:

Created on 2009-08-18 14:58 by maar, last changed 2009-08-18 17:47 by benjamin.peterson. This issue is now closed.

Messages (2)
msg91697 - (view) Author: Marcin (maar) Date: 2009-08-18 14:58
I have found bug in pyuic4.bat. I have installed python to directory
c:\programs. The path to 'python.exe' is c:\programs\python.exe. Content
of file pyuic4.bat is:

@"C:\Python25\python.exe"
"C:\Python25\Lib\site-packages\PyQt4\uic\pyuic.py" %1 %2 %3 %4 %5 %6 %7
%8 %9

In this file, during installation process it must be changed path to
python.exe.

In my example it must be done like that:

@"C:\programs\Python25\python.exe"
"C:\programs\Python25\Lib\site-packages\PyQt4\uic\pyuic.py" %1 %2 %3 %4
%5 %6 %7 %8 %9
msg91710 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2009-08-18 17:47
Please report this to the _PyQt_ maintainers.
History
Date User Action Args
2009-08-18 17:47:46benjamin.petersonsetstatus: open -> closed

nosy: + benjamin.peterson
messages: + msg91710

resolution: not a bug
2009-08-18 14:58:39maarcreate