classification
Title: Fatal error: deallocating None
Type: crash Stage:
Components: Interpreter Core Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: shashi, skip.montanaro
Priority: normal Keywords:

Created on 2009-08-10 10:35 by shashi, last changed 2009-08-10 14:34 by benjamin.peterson. This issue is now closed.

Files
File name Uploaded Description Edit
learn.py shashi, 2009-08-10 10:35 a script to make a bot learn from text files, uses another py file with text file listing.
Messages (2)
msg91438 - (view) Author: Shashi Gowda (shashi) Date: 2009-08-10 10:35
I'm using the megahal mh_python module to make a bot instance learn from
a several 100 files. The code works as it should for 4-6 files before
crashing with this error message "Fatal error: deallocating None" There
isn't much documentation on this anywhere.
msg91441 - (view) Author: Skip Montanaro (skip.montanaro) * (Python triager) Date: 2009-08-10 12:18
Is your mh_python module written in C/C++ or Python?  If it's written
in C or C++ check your Py_DECREF calls.  You are probably doubly
decrementing some object which at times refers to Py_None.  Do that
enough and you eventually try to deallocate it.

In fact, it does appear that the Megahal python wrapper is written
in C.  I don't know where the source is, but it's almost certain the
problem lies there, not in the Python interpreter core.  I suggest you
contact the Megahal author(s).
History
Date User Action Args
2009-08-10 14:34:55benjamin.petersonsetstatus: open -> closed
resolution: not a bug
2009-08-10 12:18:59skip.montanarosetnosy: + skip.montanaro
messages: + msg91441
2009-08-10 10:35:15shashicreate