classification
Title: duplicate get_version() code between cygwinccompiler and emxccompiler
Type: behavior Stage: resolved
Components: Distutils, Distutils2 Versions: 3rd party
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: jaraco Nosy List: alexis, eric.araujo, jaraco, tarek
Priority: normal Keywords:

Created on 2009-07-12 08:20 by tarek, last changed 2013-11-16 00:06 by jaraco. This issue is now closed.

Messages (7)
msg90441 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-07-12 08:20
Duplicate code, will create a single get_version() function in
distutils.util and make both commands use it + deprecate
cygwinccompiler.get_version and emxccompiler.get_version
msg113013 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2010-08-05 19:05
I am just responding so this will not show up on the 'unanswered issues' list.
msg113016 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-08-05 19:09
Tarek, does this still apply?
msg122429 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-11-26 02:55
This is done.
msg122430 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-11-26 02:58
To be more precise: the duplication is still present (and harmless) in distutils but fixed in distutils2.
msg202581 - (view) Author: Jason R. Coombs (jaraco) * (Python committer) Date: 2013-11-10 22:57
This change didn't make it into Python 3.2 but is in 2.7. see issue19544 for details.
msg202983 - (view) Author: Jason R. Coombs (jaraco) * (Python committer) Date: 2013-11-16 00:06
emxccompiler is no longer present in Python 3.4, so this ticket has become invalid.
History
Date User Action Args
2013-11-16 00:06:08jaracosetstatus: open -> closed
resolution: fixed -> not a bug
messages: + msg202983
2013-11-10 22:57:16jaracosetstatus: closed -> open

nosy: + alexis, jaraco
messages: + msg202581

assignee: tarek -> jaraco
components: + Distutils
2010-11-26 02:58:26eric.araujosetmessages: + msg122430
2010-11-26 02:55:41eric.araujosetstatus: open -> closed
nosy: tarek, eric.araujo
messages: + msg122429

components: - Distutils
resolution: fixed
stage: needs patch -> resolved
2010-09-30 02:22:03terry.reedysetnosy: - terry.reedy
2010-09-30 02:10:56eric.araujosetstage: needs patch
versions: + 3rd party, - Python 3.2
2010-08-05 19:09:17eric.araujosetversions: - Python 2.7
nosy: + eric.araujo

messages: + msg113016

components: + Distutils2
2010-08-05 19:05:24terry.reedysetnosy: + terry.reedy
messages: + msg113013
2009-07-12 08:20:40tarekcreate