classification
Title: 2to3 adds spare brackets to print
Type: behavior Stage: resolved
Components: 2to3 (2.x to 3.x conversion tool) Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder: 2to3: fix_future conflicts with fix_print
View: 6429
Assigned To: Nosy List: bazooka, r.david.murray
Priority: normal Keywords:

Created on 2009-07-09 20:16 by bazooka, last changed 2009-07-09 20:25 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
test.py bazooka, 2009-07-09 20:16
Messages (2)
msg90349 - (view) Author: Vasiliy (bazooka) Date: 2009-07-09 20:16
from __future__ import print_function
    print('Foo','Bar')
    print('FooBar')

2to3 translates it to

    print(('Foo','Bar'))
    print('FooBar')

is it right?
msg90350 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-07-09 20:25
This is a duplicate of Issue6429.
History
Date User Action Args
2009-07-09 20:25:26r.david.murraysetstatus: open -> closed
priority: normal
superseder: 2to3: fix_future conflicts with fix_print


nosy: + r.david.murray
messages: + msg90350
resolution: duplicate
stage: resolved
2009-07-09 20:17:27bazookasettitle: 2to3 adds additional brackets to print -> 2to3 adds spare brackets to print
2009-07-09 20:16:48bazookasettitle: Additional brackets to print -> 2to3 adds additional brackets to print
2009-07-09 20:16:04bazookacreate