classification
Title: imaplib.IMAP4.fetch() is missing documentation for message_set parameter
Type: Stage: resolved
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: Sjoerder, ezio.melotti, georg.brandl
Priority: low Keywords:

Created on 2009-07-06 08:18 by Sjoerder, last changed 2009-07-08 07:40 by Sjoerder. This issue is now closed.

Messages (3)
msg90165 - (view) Author: Sjoerd (Sjoerder) Date: 2009-07-06 08:18
The message_set parameter imaplib.IMAP4.fetch(message_set,
message_parts) is not a set or list, but a comma-separated string, it
seems. This could use some documentation.
msg90220 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2009-07-07 09:14
The 4th paragraph in the section IMAP4 Objects [1] specifies that:
"The message_set options to commands below is a string specifying one or
more messages to be acted upon. It may be a simple message number ('1'),
a range of message numbers ('2:4'), or a group of non-contiguous ranges
separated by commas ('1:3,6:9'). A range can contain an asterisk to
indicate an infinite upper bound ('3:*')."

A link to this paragraph could be added in the methods where message_set
is used.

[1]: http://docs.python.org/library/imaplib.html#imap4-objects
msg90255 - (view) Author: Sjoerd (Sjoerder) Date: 2009-07-08 07:40
Thanks, I missed that. I only read the documentation for the methods.
History
Date User Action Args
2009-07-08 07:40:55Sjoerdersetmessages: + msg90255
2009-07-07 09:14:25ezio.melottisetstatus: open -> closed
priority: low

versions: + Python 2.7, - Python 2.6
nosy: + ezio.melotti

messages: + msg90220
resolution: not a bug
stage: resolved
2009-07-06 08:18:37Sjoerdercreate