classification
Title: 3.1 not functional
Type: Stage: resolved
Components: Versions: Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: alexandre.vassalotti, element.effect, ezio.melotti
Priority: normal Keywords:

Created on 2009-07-03 21:17 by element.effect, last changed 2009-07-03 21:40 by element.effect. This issue is now closed.

Messages (7)
msg90076 - (view) Author: corban (element.effect) Date: 2009-07-03 21:17
After downloading v. 3.1, I couldnt get it to perform even the most 
simple functions. I am somewhat new to the programming so I dont know 
if there is something simple that I am missing or if it is a possible 
bug with the system.
msg90077 - (view) Author: Alexandre Vassalotti (alexandre.vassalotti) * (Python committer) Date: 2009-07-03 21:22
Could you elaborate on what is problem exactly? Please include any error
message you are getting. Also, what operating system are you using?
msg90078 - (view) Author: corban (element.effect) Date: 2009-07-03 21:25
I am using windows xp. I dont have the exact error message because I've 
already uninstalled in and went with v/ 2.6.2 (which seems to be 
working fine.) But it was telling me to be a syntax error and would 
always highlight the blank space after any command as if that were the 
issue.
msg90079 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2009-07-03 21:28
Maybe you used "print foo" instead of "print(foo)". In Python3 print is
a function and if you don't use the () you get this:
>>> print foo
  File "<stdin>", line 1
    print foo
            ^
SyntaxError: invalid syntax
msg90080 - (view) Author: corban (element.effect) Date: 2009-07-03 21:31
Are there many changes like this with functions because what little 
I've learned is from v. 2.6.2 and most lessons seem to be based around 
that style as well. Im trying to teach myself and need to know which 
version would be better.
msg90082 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2009-07-03 21:37
If you want to know what changed in Python 3 you can read
http://docs.python.org/3.0/whatsnew/3.0.html
If you are learning Python and you need help you can ask on
comp.lang.python or on #python (server: irc.freenode.net).
Closing as invalid.
msg90083 - (view) Author: corban (element.effect) Date: 2009-07-03 21:40
From what I can see, the older version of python may be easier to learn 
for a programming novice. It seems to be a little less complicated 
overall.
History
Date User Action Args
2009-07-03 21:40:44element.effectsetmessages: + msg90083
2009-07-03 21:37:18ezio.melottisetstatus: open -> closed
resolution: not a bug
messages: + msg90082

stage: test needed -> resolved
2009-07-03 21:31:24element.effectsetmessages: + msg90080
2009-07-03 21:28:04ezio.melottisetnosy: + ezio.melotti
messages: + msg90079
2009-07-03 21:25:39element.effectsetmessages: + msg90078
2009-07-03 21:22:48alexandre.vassalottisetnosy: + alexandre.vassalotti

messages: + msg90077
stage: test needed
2009-07-03 21:17:47element.effectcreate