classification
Title: TypeError: b2a_base64() argument 1 must be bytes or buffer, not str during SMTP.login
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.0
process
Status: closed Resolution: duplicate
Dependencies: Superseder: smtplib is broken in Python3
View: 5259
Assigned To: Nosy List: milivojm, r.david.murray
Priority: normal Keywords:

Created on 2009-06-16 08:19 by milivojm, last changed 2009-06-16 12:59 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
test.py milivojm, 2009-06-16 08:19 Python example script invoking error
Messages (2)
msg89428 - (view) Author: Milivoj Milani (milivojm) Date: 2009-06-16 08:19
When trying to send an e-mail using a tutorial like example, I get the 
following message:

Traceback (most recent call last):
  File "test.py", line 3, in <module>
    server.login("domena\someuser","somepassword")
  File "C:\Python\lib\smtplib.py", line 583, in login
    "%s %s" % (AUTH_LOGIN, encode_base64(user)))
  File "C:\Python\lib\email\base64mime.py", line 96, in body_encode
    enc = b2a_base64(s[i:i + max_unencoded]).decode("ascii")
TypeError: b2a_base64() argument 1 must be bytes or buffer, not str
msg89431 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-06-16 12:59
This is a duplicate of issue 5259, and has already been fixed.  Thanks
for the report.
History
Date User Action Args
2009-06-16 12:59:24r.david.murraysetstatus: open -> closed
priority: normal
superseder: smtplib is broken in Python3


nosy: + r.david.murray
messages: + msg89431
resolution: duplicate
stage: resolved
2009-06-16 08:19:53milivojmcreate