classification
Title: 'make framework...' fails on Mac ([...]/bin/pythonw3.1: No such file or directory)
Type: Stage:
Components: Build, macOS Versions: Python 3.1
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, ronaldoussoren, srid
Priority: normal Keywords:

Created on 2009-06-02 00:53 by srid, last changed 2009-06-02 09:15 by ronaldoussoren. This issue is now closed.

Messages (4)
msg88701 - (view) Author: Sridhar Ratnakumar (srid) Date: 2009-06-02 00:53
This happens with 3.1rc1

$ make frameworkinstallframework DESTDIR=image1
[...]
cc  -o pythonw ./Tools/pythonw.c \
               
-DPYTHONWEXECUTABLE='"/Library/Frameworks/Python.framework/Versions/3.1/Resources/Python.app/Contents/MacOS/Python"'
/usr/bin/install -c -s pythonw
"image1/Library/Frameworks/Python.framework/Versions/3.1/bin/pythonw3.1"
install:
image1/Library/Frameworks/Python.framework/Versions/3.1/bin/pythonw3.1:
No such file or directory
make[1]: *** [install_pythonw] Error 71
make: *** [frameworkinstallapps] Error 2
$
msg88722 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2009-06-02 07:21
See also Issue6170.
msg88727 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2009-06-02 09:02
I cannot reproduce this with the py3k branch, I'm currently building 
r31rc1 to check if I can reproduce the issue with that.
msg88729 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2009-06-02 09:15
The build was quicker than expected. I also cannot reproduce using 
r31rc1.


Or rather, I can reproduce this using "make frameworkinstallframework", 
but not using "make install".

The latter is the correct way to install the framework, the former is an 
internal makefile target that is used during installation but should not 
be used on its own.

Closing this as won't fix.
History
Date User Action Args
2009-06-02 09:15:06ronaldoussorensetstatus: open -> closed
resolution: wont fix
messages: + msg88729
2009-06-02 09:02:30ronaldoussorensetmessages: + msg88727
2009-06-02 07:21:45ned.deilysetnosy: + ronaldoussoren, ned.deily
messages: + msg88722
2009-06-02 00:53:31sridcreate