classification
Title: Missing Shell menu in Linux IDLE
Type: Stage:
Components: IDLE Versions: Python 3.0, Python 2.7, Python 2.6, Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: gpolo, roger.serwy, sirgimp
Priority: normal Keywords:

Created on 2009-06-01 20:59 by sirgimp, last changed 2009-08-07 16:43 by gpolo. This issue is now closed.

Files
File name Uploaded Description Edit
unnamed sirgimp, 2009-06-01 23:49
unnamed sirgimp, 2009-06-02 02:29
Messages (6)
msg88677 - (view) Author: Jason Gervich (sirgimp) Date: 2009-06-01 20:59
The Shell menu is missing from the menu bar in the Edit Window of Ubuntu
Linux IDLE. It is described in the help but is not implemented. It is
there is the various windows versions I've seen.

Why is this missing and will it be fixed?
msg88681 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2009-06-01 22:09
Running IDLE from the Applications menu under Ubuntu will not have the
Shell menu. If you bring up a terminal and enter "idle", you will have
the Shell menu.

IDLE, when selected from the Application menu, is being run with the
"-n" command line by default in Ubuntu. You can remove this option by
editing the menu item for IDLE.
msg88687 - (view) Author: Jason Gervich (sirgimp) Date: 2009-06-01 23:49
Thank you. I tried it from the command line and you are right. IDLE runs
with the Shell menu.

1.Do you know why this is being done in Ubuntu? That is, why are they
setting up the menu this way?

2. Is it a bug or a "feature?" Should be reported a an Ubuntu bug?

How do I edit the IDLE menu item?

Thanks again, 

Roger

On Mon, 2009-06-01 at 22:09 +0000, Roger Serwy wrote:

> Roger Serwy <roger.serwy@gmail.com> added the comment:
> 
> Running IDLE from the Applications menu under Ubuntu will not have the
> Shell menu. If you bring up a terminal and enter "idle", you will have
> the Shell menu.
> 
> IDLE, when selected from the Application menu, is being run with the
> "-n" command line by default in Ubuntu. You can remove this option by
> editing the menu item for IDLE.
> 
> ----------
> nosy: +serwy
> 
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue6168>
> _______________________________________
msg88702 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2009-06-02 00:53
You'll need to modify the IDLE menu item to remove the "-n" using
Ubuntu's menu modification tool, usually found under System->Preferences.

Presently, using a subprocess only allows for one instance of IDLE
running on a machine, whereas running with no subprocess allows for many
instances of IDLE. This architecture is by design.

Check out Ubuntu bug 338379.
msg88708 - (view) Author: Jason Gervich (sirgimp) Date: 2009-06-02 02:29
Again, thanks for your prompt explanation.

It's odd, but when I went to use Ubuntu's menu modification tool, the
command displayed in the dialog didn't show the -n option.

But when I added the Python launcher to the panel and viewed the launch
command via the properties dialog, the -n was there and I was easily
able to remove it. 

So if I run Python from the modified icon in the panel, it launches
without the -n option. But if I run it from the Application Menu, it
runs without the -n option. It seems to me that the -n option should be
available when viewing it from the menu modification tool, but it's not.

I guess Windows doesn't have this problem with running IDLE with a
subprocess. I was able to run several instances of the IDLE shell with
the Shell menu displayed.

On Tue, 2009-06-02 at 00:53 +0000, Roger Serwy wrote:

> Roger Serwy <roger.serwy@gmail.com> added the comment:
> 
> You'll need to modify the IDLE menu item to remove the "-n" using
> Ubuntu's menu modification tool, usually found under System->Preferences.
> 
> Presently, using a subprocess only allows for one instance of IDLE
> running on a machine, whereas running with no subprocess allows for many
> instances of IDLE. This architecture is by design.
> 
> Check out Ubuntu bug 338379.
> 
> ----------
> 
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue6168>
> _______________________________________
msg91407 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2009-08-07 16:43
From what I read here this is not a problem caused by the sources
distributed by python.org, so I'm closing this. It seems more
appropriate to move this to Ubuntu's bug tracker.
History
Date User Action Args
2009-08-07 16:43:33gpolosetstatus: open -> closed

nosy: + gpolo
messages: + msg91407

resolution: not a bug
2009-06-02 02:29:15sirgimpsetfiles: + unnamed

messages: + msg88708
2009-06-02 00:53:50roger.serwysetmessages: + msg88702
2009-06-01 23:49:40sirgimpsetfiles: + unnamed

messages: + msg88687
2009-06-01 22:09:43roger.serwysetnosy: + roger.serwy
messages: + msg88681
2009-06-01 20:59:43sirgimpcreate