classification
Title: './configure; make install' fails in setup.py step if .pydistutils.cfg specifies 'home'
Type: compile error Stage: resolved
Components: Versions: Python 3.1, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: during Python installation, setup.py should not use .pydistutils.cfg
View: 4655
Assigned To: Nosy List: eric.araujo, ned.deily, r.david.murray, tarek
Priority: normal Keywords:

Created on 2009-05-28 21:01 by r.david.murray, last changed 2013-02-20 08:53 by ned.deily. This issue is now closed.

Messages (8)
msg88476 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-05-28 21:01
With current trunk, after a make distclean; ./configure; make install
sequence, I get the following error:

[...]
# Substitution happens here, as the completely-expanded BINDIR
# is not available in configure
sed -e "s,@EXENAME@,/usr/local/bin/python2.7," < ./Misc/python-config.in
>python-config
/usr/bin/install -c python-config /usr/local/bin/python2.7-config
rm python-config
./python -E ./setup.py install \
                --prefix=/usr/local \
                --install-scripts=/usr/local/bin \
                --install-platlib=/usr/local/lib/python2.7/lib-dynload \
                --root=/
running install
error: must supply either home or prefix/exec-prefix -- not both
make: *** [sharedinstall] Error 1
msg88477 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-05-28 21:25
works for me under MacOS X, I am trying now under debian
msg88478 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-05-28 21:34
Benjamin can't reproduce it either.  Must be something weird in my
environment, so I'm lowering the priority.
msg88481 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-05-28 21:46
Ok.

I confirm it works fine on a standard debian as well
msg88482 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-05-28 21:48
I can see that 'self.home' is '~' when that error message is generated,
but I can't figure out where self.home gets set.  Any clues you can give me?
msg88485 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-05-28 22:24
I figured it out.  It turns out that a while back I created a
.pydistutils.cfg file and put home in there.

There is a bug here, of some sort.  Either the .pydistutils.cfg file's
install clause should override the default --prefix somehow, or the
error message should indicate where the setting for 'home' and
'--prefix' came from to enable the user to debug the configuration.  In
the latter case there would also need to be a way to explicitly tell
either make install or configure to ignore .pydistutils.cfg.  In the
former case, an explicit --prefix passed to configure would need to
override .pydistutils.cfg.

Or perhaps there's some other solution I'm not seeing at the moment.
msg121411 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-11-18 01:58
See #4655.  (Not sure which one is the superseder.)
msg182482 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-02-20 08:53
Let's consolidate these.
History
Date User Action Args
2013-02-20 08:53:50ned.deilysetstatus: open -> closed

superseder: during Python installation, setup.py should not use .pydistutils.cfg

nosy: + ned.deily
messages: + msg182482
resolution: duplicate
stage: resolved
2010-11-18 01:58:45eric.araujosetnosy: + eric.araujo
messages: + msg121411
2009-05-28 22:24:31r.david.murraysetmessages: + msg88485
title: ./configure; make install fails in setup.py step -> './configure; make install' fails in setup.py step if .pydistutils.cfg specifies 'home'
2009-05-28 21:48:35r.david.murraysetmessages: + msg88482
2009-05-28 21:46:50tareksetmessages: + msg88481
2009-05-28 21:34:36r.david.murraysetpriority: release blocker -> normal

messages: + msg88478
2009-05-28 21:25:30tareksetmessages: + msg88477
2009-05-28 21:01:53r.david.murraycreate