classification
Title: IDLE has two "Preferences..." menu's on OSX
Type: behavior Stage:
Components: IDLE, macOS Versions: Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, ronaldoussoren
Priority: normal Keywords:

Created on 2009-05-26 06:51 by ronaldoussoren, last changed 2009-05-26 18:50 by ronaldoussoren. This issue is now closed.

Messages (4)
msg88332 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2009-05-26 06:51
With Python 2.7, but not 3.1 or 2.6, IDLE has two "Preferences..." menu's 
on OSX. 

This is on a OSX 10.5 system, with an installation of Tcl/Tk 8.4 in 
/Library/Frameworks.
msg88382 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2009-05-26 18:45
Apparently, also caused by using the newer Tcl 8.4 in 
/Library/Frameworks/Tcl.
msg88383 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2009-05-26 18:48
This was caused by code in macosxSupport.py that picked the branch for
the wrong Tk release because "[8, 4, 21] < (8, 4, 21)". 

Committed a fix in r72946
msg88384 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2009-05-26 18:50
Supporting multiple versions of Tk sucks, and that's without trying to
support Tk 8.5 as well (at least not in the binary installers)

Appearently support for the Cocoa port of Tk requires even more
specialcasing...
History
Date User Action Args
2009-05-26 18:50:04ronaldoussorensetmessages: + msg88384
2009-05-26 18:48:25ronaldoussorensetstatus: open -> closed
resolution: fixed
messages: + msg88383
2009-05-26 18:46:00ned.deilysetnosy: + ned.deily
messages: + msg88382
2009-05-26 06:51:51ronaldoussorencreate