classification
Title: Use shipped zlib if the system version is bad
Type: enhancement Stage: resolved
Components: Build Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ajaksu2
Priority: normal Keywords: patch

Created on 2009-05-14 02:05 by ajaksu2, last changed 2009-05-14 03:33 by ajaksu2. This issue is now closed.

Files
File name Uploaded Description Edit
zlib_setup.diff ajaksu2, 2009-05-14 02:05 Patch against trunk, seems to apply fine on py3k.
Messages (2)
msg87727 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-05-14 02:05
The attached patch makes setup.py use the shipped zlib.h in
Modules/zlib/ when a bogus zlib.h is found by find_file.

However, I couldn't test it (nor make it work) when a system zlib is
missing (no time right now). Can we build the shipped zlib and link
against it?
msg87728 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-05-14 03:33
We'd be asking for trouble with this: incompatible shipped and system
versions or having to build the shipped version. All that for working
around the rare case where the user doesn't have a valid zlib makes no
sense :)
History
Date User Action Args
2009-05-14 03:33:22ajaksu2setstatus: open -> closed
messages: + msg87728

keywords: patch, patch
resolution: not a bug
stage: test needed -> resolved
2009-05-14 02:05:46ajaksu2create