classification
Title: Idle should be installed as `idle3.1` and not `idle3`
Type: Stage:
Components: IDLE Versions: Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, srid
Priority: normal Keywords:

Created on 2009-05-13 00:49 by srid, last changed 2010-10-28 09:08 by ned.deily. This issue is now closed.

Messages (3)
msg87664 - (view) Author: Sridhar Ratnakumar (srid) Date: 2009-05-13 00:49
In Python2.x, Idle is installed as idle2.x. This is the case with Linux
and Mac.

However, in Py3.1b2, Idle is installed as `idle3`. 

Expected script name is `idle3.1`.
msg112170 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-07-31 17:25
Can someone with Linux and/or Mac confirm whether or not this is still an issue.
msg113237 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-08-08 07:23
For OS X installer builds, this was fixed by r72723 prior to the final release of 3.1; idle is installed in the framework bin directory as idle3 with a symlink to the versioned name, i.e. idle3.n, and the optional UNIX command-line tools package installs symlinks in /usr/local/bin to both names.

For Linux, it's up to the various distributors on how they package Python 3.  For instance, it appears Debian has chosen to install the idle script as /usr/bin/idle-python3.1
History
Date User Action Args
2010-10-28 09:08:06ned.deilysetstatus: open -> closed
nosy: - BreamoreBoy
resolution: not a bug
2010-08-08 07:23:24ned.deilysetnosy: + ned.deily
messages: + msg113237
2010-07-31 17:25:17BreamoreBoysetnosy: + BreamoreBoy
messages: + msg112170
2009-05-13 00:49:51sridcreate