classification
Title: compile error - PyNumber_InPlaceOr(newfree, allfree) < 0
Type: compile error Stage: needs patch
Components: Build Versions: Python 3.0, Python 3.1
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: benjamin.peterson Nosy List: benjamin.peterson, mark.dickinson, pitrou, srid
Priority: release blocker Keywords: easy

Created on 2009-05-11 21:29 by srid, last changed 2009-05-12 20:39 by benjamin.peterson. This issue is now closed.

Messages (4)
msg87589 - (view) Author: Sridhar Ratnakumar (srid) Date: 2009-05-11 21:29
cc_r -qlanglvl=ansi -c  -DNDEBUG -O  -I. -IInclude -I./Include  
-DPy_BUILD_CORE -o Python/symtable.o Python/symtable.c
"Python/symtable.c", line 767.50: 1506-068 (S) Operation between types
"struct _object*" and "int" is not allowed.
"Python/symtable.c", line 826.55: 1506-068 (S) Operation between types
"struct _object*" and "int" is not allowed.
make: *** [Python/symtable.o] Error 1

!
!
!

The lines causing the error is:

	if (PyNumber_InPlaceOr(newfree, allfree) < 0)
		goto error;

...

	if (PyNumber_InPlaceOr(child_free, temp_free) < 0)
		goto error;


!
!
!

On HP-UX 11.00 (parisc and parisc2.0), the error message is:

cc +DAportable -Ae -D_REENTRANT +Z -c  -DNDEBUG -O  -I. -IInclude
-I./Include   -DPy_BUILD_CORE -o Python/symtable.o Python/symtable.c
cc: "Python/symtable.c", line 767: error 1649: Illegal integer-pointer
combination for <.
cc: "Python/symtable.c", line 767: error 1563: Expression in if must be
scalar.
cc: "Python/symtable.c", line 826: error 1649: Illegal integer-pointer
combination for <.
cc: "Python/symtable.c", line 826: error 1563: Expression in if must be
scalar.
make: *** [Python/symtable.o] Error 1


!
!
!

When I get time, I need to create a patch to fix this.. but if somebody
else already figured out what the issue is, that'd be great too.
msg87630 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-05-12 13:44
Hmm, PyNumber_InPlaceOr() returns a PyObject*, no wonder why the
compiler complains.
I suppose gcc and MSVC and /really/ laxist to let this error fall through.
msg87639 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2009-05-12 15:53
The error's also in 3.0.
msg87659 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2009-05-12 20:39
Fixed in r72589.
History
Date User Action Args
2009-05-12 20:39:42benjamin.petersonsetstatus: open -> closed
resolution: fixed
messages: + msg87659
2009-05-12 18:11:44benjamin.petersonsetpriority: critical -> release blocker
assignee: benjamin.peterson

nosy: + benjamin.peterson
2009-05-12 15:53:22mark.dickinsonsetnosy: + mark.dickinson

messages: + msg87639
versions: + Python 3.0
2009-05-12 13:44:50pitrousetpriority: critical

title: compile error on AIX and HP-UX 11.00 - PyNumber_InPlaceOr(newfree, allfree) < 0 -> compile error - PyNumber_InPlaceOr(newfree, allfree) < 0
keywords: + easy
nosy: + pitrou

messages: + msg87630
stage: needs patch
2009-05-11 21:29:35sridcreate