classification
Title: multiprocessing 'using a remote manager' example errors and possible 'from_address' code leftover
Type: behavior Stage: resolved
Components: Documentation, Library (Lib) Versions: Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: multiprocessing: BaseManager.from_address documented but doesn't exist
View: 3518
Assigned To: jnoller Nosy List: alexdutton, asksol, berker.peksag, cmcginty, georg.brandl, jnoller, r.david.murray
Priority: normal Keywords:

Created on 2009-04-28 01:55 by r.david.murray, last changed 2014-06-29 10:41 by berker.peksag. This issue is now closed.

Files
File name Uploaded Description Edit
log.txt r.david.murray, 2009-04-28 16:14 code of examples run, with debugging output
Messages (5)
msg86715 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-04-28 01:55
The 'Using a remote manager' section of the multiprocessing docs has an
example of calling the (documented) 'from_address' class method of
BaseManager.  However, no such method appears to exist. I don't know if
this is a doc bug or a code bug. The __reduce__ method of BaseManager
calls type(self).from_address, and that and a similar pickle-related
call in sharedctypes are the only places it is mentioned in the module.
 It is not mentioned in the test suite.

In any case, the example does not work as written, and there appear to
be multiple errors in the "another client" (the read client) example.  I
haven't played with the "local client" example at all.
msg86730 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2009-04-28 12:46
Ugh, I do think this is a doc bug; I think there was an amount of shear 
when we performed the merge into core and subsequent bug fixes. I'll take 
a look when I get a chance.
msg86751 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-04-28 16:14
OK, so I made the obvious changes to the second remote client example
and tried running the three.  They all run now, but the output is not as
expected.  I've attached a composite debug log of what happened for your
reference.  (I think I ran either t2 or t3 twice, which is why the t1
log shows three sets of messages).  You will note that this reveals a
logging bug of some sort, as well.

I checked the obvious fixups to the second remote client example in with
my other doc fixes in r72060.
msg115079 - (view) Author: Ask Solem (asksol) (Python committer) Date: 2010-08-27 14:14
Duplicate of 3518?
msg221835 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2014-06-29 10:41
This has already been fixed in issue 3518:

    https://docs.python.org/3.4/library/multiprocessing.html#using-a-remote-manager
History
Date User Action Args
2014-06-29 10:41:48berker.peksagsetstatus: open -> closed

superseder: multiprocessing: BaseManager.from_address documented but doesn't exist

nosy: + berker.peksag
messages: + msg221835
resolution: duplicate
stage: needs patch -> resolved
2014-06-27 21:23:01BreamoreBoysetversions: + Python 3.4, Python 3.5, - Python 2.6, Python 3.0, Python 3.1
2010-08-27 14:14:29asksolsetnosy: + asksol
messages: + msg115079
2009-11-19 11:51:38alexduttonsetnosy: + alexdutton
2009-07-09 22:43:31cmcgintysetnosy: + cmcginty
2009-04-28 16:14:19r.david.murraysetfiles: + log.txt

messages: + msg86751
2009-04-28 12:46:50jnollersetmessages: + msg86730
2009-04-28 02:56:42benjamin.petersonsetassignee: georg.brandl -> jnoller
2009-04-28 01:55:01r.david.murraycreate