classification
Title: Idle 3.01 - invalid syntec error
Type: compile error Stage:
Components: IDLE Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: doerwalter, r2d2floyd
Priority: normal Keywords:

Created on 2009-04-26 21:52 by r2d2floyd, last changed 2009-04-26 21:57 by doerwalter. This issue is now closed.

Files
File name Uploaded Description Edit
odbchelper.py r2d2floyd, 2009-04-26 21:52 From book "Diving into Python"
Messages (2)
msg86609 - (view) Author: R.D. floyd (r2d2floyd) Date: 2009-04-26 21:52
Recently upgraded to OS 10.5, Experienced Fortran, Basic, et. al.
programmer learning Python. IDLE 3.01 give invalid syntec error when
running program below. IDLE from MacPython 2.xx runs it ok!
msg86610 - (view) Author: Walter Dörwald (doerwalter) * (Python committer) Date: 2009-04-26 21:57
This is not a bug in Python.

In Python 3.0 "print" is a function, so

   print buildConnectionString(myParams)

should read

   print(buildConnectionString(myParams))

Closing as invalid.
History
Date User Action Args
2009-04-26 21:57:33doerwaltersetstatus: open -> closed

nosy: + doerwalter
messages: + msg86610

resolution: not a bug
2009-04-26 21:52:17r2d2floydcreate