classification
Title: RegOpenKeyEx key failed on Vista 64Bit with return 2
Type: behavior Stage:
Components: Versions: Python 2.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, loewis, makursi
Priority: normal Keywords:

Created on 2009-04-25 12:50 by makursi, last changed 2010-02-18 18:05 by loewis. This issue is now closed.

Messages (3)
msg86497 - (view) Author: Makursi (makursi) Date: 2009-04-25 12:50
I have installed 2.6.2 source(32bit) on Vista 64 bit. 
The function RegOpenKeyEx fails with returns "2". 
If I change the function to  
		rc=RegOpenKeyEx(keyBase,
			keyBuf, /* subkey */
			0, /* reserved */
			KEY_READ | KEY_WOW64_64KEY,
			&newKey);
it works fine. I have checked this in the debug build with my 32 bit 
C++ application. UAC is not enabled on my machine.
I hope the issue is fixed with the next version of python.

Regards
Manfred
msg88858 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-06-04 00:24
I don't understand what "2.6.2 source(32bit)" is.
Did you install a binary distribution (.msi), or did you compile the 
source files?
msg99518 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-02-18 18:05
Closing because of lack of feedback.
History
Date User Action Args
2010-02-18 18:05:17loewissetstatus: open -> closed

nosy: + loewis
messages: + msg99518

resolution: out of date
2009-06-04 00:24:44amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg88858
2009-04-25 12:50:37makursicreate