classification
Title: MySQL crash on machine startup....
Type: Stage: resolved
Components: Installation Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: loewis, plattecoducks, r.david.murray
Priority: normal Keywords:

Created on 2009-04-21 14:41 by plattecoducks, last changed 2009-04-21 21:52 by plattecoducks. This issue is now closed.

Files
File name Uploaded Description Edit
unnamed plattecoducks, 2009-04-21 21:52
Messages (7)
msg86231 - (view) Author: Dave Fliger (plattecoducks) Date: 2009-04-21 14:41
I recently (in the last 5 days) downloaded and installed Python 2.6.x. 
Upon startup of this machine I noticed a Windows warning 
that "mysqld.exe could not start...". I really didn't pay attention to 
it until today since I had no plans to use MySQL or any other app that 
might use it.

I also use XAMPP, which does rely on MySQL. This morning when I started 
XAMPP, the MySQL server crashed on startup of XAMPP. I removed Python 
by uninstalling it, set XAMPP to start on startup and rebooted. 
Bingo!!!! No problem.

Seems like the install process does not check for other applications 
using MySQL and appropriates the db for itself. Is this correct? If 
that is correct, then the install process needs to be altered. 

Is this an issue? I don't know. You tell me.
msg86248 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-04-21 16:29
Python doesn't care about mysql.  You can use a third party library to
talk to mysql from python, but only if you install that third party
library. Otherwise, python isn't even aware of whether or not mysql is
installed. So whatever the problem is, it is very unlikely that it has
anything to do with your python install.

If your mysqld starts failing again after reinstalling python, then I'd
suggest posting to python-list and see if the community can help you
narrow down the problem.  If for some bizarre reason it does turn out to
be an issue with the python install, you can open a new ticket with more
information, or reopen this one.
msg86249 - (view) Author: Dave Fliger (plattecoducks) Date: 2009-04-21 16:34
Thanks for the response. I wasn't sure what the deal was, and sort of intuitively knew it wasn't the problem. I wouldn't have mentioned it with the exception that uninstalling solved the problem. That's a bit odd, don't you think?
 
Dave Fliger
Webmaster
Rogers Sporting Goods
1760 N. Church Road
Liberty, MO 64068
(816) 781 9026
 

________________________________
From: R. David Murray <report@bugs.python.org>
To: plattecountyducks@yahoo.com
Sent: Tuesday, April 21, 2009 11:29:23 AM
Subject: [issue5806] MySQL crash on machine startup....

R. David Murray <rdmurray@bitdance.com> added the comment:

Python doesn't care about mysql.  You can use a third party library to
talk to mysql from python, but only if you install that third party
library. Otherwise, python isn't even aware of whether or not mysql is
installed. So whatever the problem is, it is very unlikely that it has
anything to do with your python install.

If your mysqld starts failing again after reinstalling python, then I'd
suggest posting to python-list and see if the community can help you
narrow down the problem.  If for some bizarre reason it does turn out to
be an issue with the python install, you can open a new ticket with more
information, or reopen this one.

----------
nosy: +r.david.murray
resolution:  -> invalid
stage:  -> committed/rejected
status: open -> closed
type: crash -> 

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue5806>
_______________________________________
msg86250 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-04-21 16:39
Well, you mentioned that you also added something to your startup...so
it wasn't _only_ uninstalling python.  That's why I suggested
resinstalling it and seeing if things broke again...and then if it did
getting help to track down why, because as I said python doesn't touch
mysql.  (Doesn't touch it even if you install the 3rd party mysql
interface library...when you do that it just installs a client program).
msg86251 - (view) Author: Dave Fliger (plattecoducks) Date: 2009-04-21 16:41
Thank you, sir. I'll try that later in the day. I just don't want to "break" what I have. I'm eager to look under the hood of Python.
 
Dave Fliger
Webmaster
Rogers Sporting Goods
1760 N. Church Road
Liberty, MO 64068
(816) 781 9026
 

________________________________
From: R. David Murray <report@bugs.python.org>
To: plattecountyducks@yahoo.com
Sent: Tuesday, April 21, 2009 11:39:24 AM
Subject: [issue5806] MySQL crash on machine startup....

R. David Murray <rdmurray@bitdance.com> added the comment:

Well, you mentioned that you also added something to your startup...so
it wasn't _only_ uninstalling python.  That's why I suggested
resinstalling it and seeing if things broke again...and then if it did
getting help to track down why, because as I said python doesn't touch
mysql.  (Doesn't touch it even if you install the 3rd party mysql
interface library...when you do that it just installs a client program).

----------

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue5806>
_______________________________________
msg86260 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-04-21 21:18
As David says: Python has no business with mysql. If they interfere, it
could be because of a bug in Python, or because of a bug in mysql, or
because of a bug in Windows, or because of a plain misconfiguration on
your side.

So unless you can provide detailed instructions on how to reproduce it,
there is likely little that we can do.
msg86261 - (view) Author: Dave Fliger (plattecoducks) Date: 2009-04-21 21:52
True enough, my friend. I really didn't know if it had been reported before. If I go over the sequence of events tat I performed here on this machine, then my only conclusion was the installation of Python because everything worked prior to that. I know that if I can't give you the steps to reproduce, there is no problem.

So I guess this is an alert. If someone else reports something similar, you may have an issue. My original post clearly said that I didn't know if it was an issue or not.
 
Dave Fliger
Webmaster
Rogers Sporting Goods
1760 N. Church Road
Liberty, MO 64068
(816) 781 9026
 

________________________________
From: ""Martin v. Löwis" <report@bugs.python.org>@psf.upfronthosting.co.za" <=?utf-8?b?Ik1hcnRpbiB2LiBMw7Z3aXMiIDxyZXBvcnRAYnVncy5weXRob24ub3JnPg==?=@psf.upfronthosting.co.za>
To: plattecountyducks@yahoo.com
Sent: Tuesday, April 21, 2009 4:18:53 PM
Subject: [issue5806] MySQL crash on machine startup....

Martin v. Löwis <martin@v.loewis.de> added the comment:

As David says: Python has no business with mysql. If they interfere, it
could be because of a bug in Python, or because of a bug in mysql, or
because of a bug in Windows, or because of a plain misconfiguration on
your side.

So unless you can provide detailed instructions on how to reproduce it,
there is likely little that we can do.

----------
nosy: +loewis

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue5806>
_______________________________________
History
Date User Action Args
2009-04-21 21:52:32plattecoduckssetfiles: + unnamed

messages: + msg86261
2009-04-21 21:18:51loewissetnosy: + loewis
messages: + msg86260
2009-04-21 21:17:02loewissetfiles: - unnamed
2009-04-21 21:16:58loewissetfiles: - unnamed
2009-04-21 16:41:25plattecoduckssetfiles: + unnamed

messages: + msg86251
2009-04-21 16:39:23r.david.murraysetmessages: + msg86250
2009-04-21 16:34:36plattecoduckssetfiles: + unnamed

messages: + msg86249
2009-04-21 16:29:21r.david.murraysetstatus: open -> closed

type: crash ->

nosy: + r.david.murray
messages: + msg86248
resolution: not a bug
stage: resolved
2009-04-21 14:41:31plattecoduckscreate