classification
Title: unable to search in python V3 documentation
Type: resource usage Stage:
Components: Documentation Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: aotto1968, georg.brandl, terry.reedy
Priority: normal Keywords:

Created on 2009-04-17 08:29 by aotto1968, last changed 2009-04-18 07:54 by georg.brandl. This issue is now closed.

Messages (3)
msg86057 - (view) Author: Andreas Otto (aotto1968) Date: 2009-04-17 08:29
Hi,

  if I search for "sys.argv" I get


Your search did not match any documents. Please make sure that all words
are spelled correctly and that you've selected enough categories.

but its available at: http://docs.python.org/3.0/library/sys.html
msg86106 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2009-04-18 07:40
You should have searched for "sys argv" since "sys.argv" is not 'a
word'.  However, that would not have worked since multiple word
searching seems to be broken, at least sometimes.  In particular,
searching for 'argv' gives several hits, including the one you wanted,
as does searching for 'sys', but 'sys argv' does not.  I tried another
example using two words from a particular doc and got a similar failure.
msg86108 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2009-04-18 07:54
Thanks for the report, searching for dotted identifiers is implemented
now in the trunk version of Sphinx.
History
Date User Action Args
2009-04-18 07:54:17georg.brandlsetstatus: open -> closed
resolution: fixed
messages: + msg86108
2009-04-18 07:40:42terry.reedysetnosy: + terry.reedy
messages: + msg86106
2009-04-17 08:29:55aotto1968create