classification
Title: Interpreter fails to initialize on build dir when IO encoding is one of CJK
Type: crash Stage: resolved
Components: Interpreter Core Versions: Python 3.1
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: hyeshik.chang, vstinner
Priority: low Keywords:

Created on 2009-04-02 09:25 by hyeshik.chang, last changed 2017-02-14 10:03 by vstinner. This issue is now closed.

Messages (3)
msg85187 - (view) Author: Hyeshik Chang (hyeshik.chang) * (Python committer) Date: 2009-04-02 09:25
When a developer uses one of CJK encodings, interpreter crashes while
its initialization on build dir (not on installed base).

% LC_ALL=ko_KR.eucKR ./python
Fatal Python error: Py_Initialize: can't initialize sys standard streams
LookupError: unknown encoding: euc_kr
zsh: abort (core dumped)  LC_ALL=ko_KR.eucKR ./python

The problem is that codec lookup function fails to import a relevant
codec module because path to dynamic modules is added by site.py, which
is a later step than standard I/O object initializations.
msg116572 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-09-16 16:27
Hum, a low priority interpreter core crash, would anyone like to comment?
msg287754 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-02-14 10:03
I'm unable to reproduce the bug. It seems like it was fixed since 8 years ;-)

haypo@selma$ LC_ALL=ko_KR.eucKR ./python
Python 3.7.0a0 (default, Feb 14 2017, 10:48:09) 
[GCC 6.3.1 20161221 (Red Hat 6.3.1-1)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> 

haypo@selma$ LC_ALL=ko_KR.eucKR ./python -S
Python 3.7.0a0 (default, Feb 14 2017, 10:48:09) 
[GCC 6.3.1 20161221 (Red Hat 6.3.1-1)] on linux
>>>
History
Date User Action Args
2017-02-14 10:03:30vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg287754

resolution: fixed
stage: resolved
2014-02-03 19:45:17BreamoreBoysetnosy: - BreamoreBoy
2010-09-16 16:27:39BreamoreBoysetnosy: + BreamoreBoy
messages: + msg116572
2009-04-02 09:27:00hyeshik.changsettitle: Interpreter fails to initialize when IO encoding is one of CJK on build dir -> Interpreter fails to initialize on build dir when IO encoding is one of CJK
2009-04-02 09:25:39hyeshik.changcreate