classification
Title: Subversion problem with PythonLauncher after building 3.0 or 3.1 on Mac
Type: Stage:
Components: Build Versions: Python 3.0, Python 3.1
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: MLModel, loewis, ned.deily, ronaldoussoren
Priority: normal Keywords:

Created on 2009-02-15 00:33 by MLModel, last changed 2009-06-03 22:20 by ronaldoussoren. This issue is now closed.

Messages (8)
msg82135 - (view) Author: Mitchell Model (MLModel) Date: 2009-02-15 00:33
After checking out 3.0 and 3.1 and building them on a Mac (Leopard, 
Intel) when I subsequently try to do "svn update" I get the error:

svn: Directory 'Mac/PythonLauncher/Python Launcher.app/.svn' containing 
working copy admin area is missing

As a result, "svn update" fails. Removing PythonLauncher.app fixes.
This problem does NOT happen in Python2.6 even though there's no 
PythonLauncher.app/.svn there either. I don't know enough about 
subversion to disentangle this.

And in fact there is a .svn directory in Mac/IDLE/Idle.app but none in 
PythonLauncher.app. "make clean" doesn't remove the .app's; perhaps it 
should.

[Am I mistaken in building my subversion directories?]
msg82141 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-02-15 08:09
How precisely did you build? Can you check whether any build step
removed PythonLauncher, then recreated it?

If you remove Python Launcher.app, you should be able to svn update.
msg82146 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2009-02-15 09:39
There are various steps in the Mac build process where the files are 
copied from the build source to the build destination and then .svn 
directories (among other things) are removed.  Perhaps you tried building 
using the source directory as the destination directory?
msg82178 - (view) Author: Mitchell Model (MLModel) Date: 2009-02-15 22:51
>Ned Deily <nad@acm.org> added the comment:
>
>There are various steps in the Mac build process where the files are
>copied from the build source to the build destination and then .svn
>directories (among other things) are removed.  Perhaps you tried building
>using the source directory as the destination directory?
>

See my previous message. The question is whether I should be doing the build from the src directory. It works fine in all respects -- it creates a build subdirectory and does everything in there. For IDLE.app it does create a .svn but for PythonLauncher.app it doesn't. Either "make clean" or something else I'm not doing should remove all of the .app packages entirely or the build process should leave behind a .svn in each of the .app packages. Are there build instructions somewhere that say I should be doing something other than what I'm doing? I really want to know. I've been hanging out in the background studying, using, and teaching Python for years, building it on Mac G4's and an Intel MacBook Pro, and even on Window machines, but am only now starting to contribute to the community, so I appreciate any guidance or clarification anyone wants to offer.
msg82190 - (view) Author: Mitchell Model (MLModel) Date: 2009-02-16 00:00
>Martin v. Löwis <martin@v.loewis.de> added the comment:
>
>How precisely did you build? Can you check whether any build step
>removed PythonLauncher, then recreated it?

in the svn directory for, say, py3k

% svn update
% make clean
% ./configure --enable-frameworks
% make
% sudo make install

>
>If you remove Python Launcher.app, you should be able to svn update.

Yes, that's what I've been doing.
msg82191 - (view) Author: Mitchell Model (MLModel) Date: 2009-02-16 00:07
Sorry -- msg 82178 refers to "my previous message" but I sent them out of 
order. The "previous message" was 82190, just below 82178.
msg82220 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2009-02-16 07:01
I see what the problem is. In 2.x, the PythonLauncher Makefile uses 
bundlebuilder to build Python Launcher.app in Mac/PythonLauncher and 
from there it gets installed into /Applications/Python nn. Because 
bundlebuilder was removed in 3.0, r64618 checked in a copy of Python 
Launcher.app into Mac/PythonLauncher.  Later, in r68062, the build was 
changed to use a private copy of bundlebuilder so now Python 
Launcher.app is again built as in 2.x.  However, the checked-in copy of 
the app was not deleted from the svn trees and, because everything under 
the app is clobbered by the build including the .svn directories, svn 
gets upset.

The fix is easy: someone needs to svn rm Mac/PythonLauncher/Python 
Launcher.app/* from py3k and 30.  Adding Ronald to the nosy list.

So what you are doing should be fine.  Until the trees are updated, one 
way to workaround it is by making a copy of the pristine app directory 
before a build and copying it back each time you do an svn update.
msg88834 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2009-06-03 22:20
Fixed for 3.1 in r73187, and for 3.0 in r73188.
History
Date User Action Args
2009-06-03 22:20:02ronaldoussorensetstatus: open -> closed
resolution: fixed
messages: + msg88834
2009-04-01 17:52:15ronaldoussorensetassignee: ronaldoussoren
2009-02-16 07:01:19ned.deilysetnosy: + ronaldoussoren
messages: + msg82220
2009-02-16 00:07:38MLModelsetmessages: + msg82191
2009-02-16 00:00:30MLModelsetmessages: + msg82190
2009-02-15 22:51:49MLModelsetmessages: + msg82178
2009-02-15 09:39:00ned.deilysetnosy: + ned.deily
messages: + msg82146
2009-02-15 08:09:40loewissetnosy: + loewis
messages: + msg82141
2009-02-15 00:33:11MLModelcreate