classification
Title: distutils upload should prompt for the user/password too
Type: enhancement Stage: resolved
Components: Distutils Versions: Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: distutils crashes when uploading to PyPI having only the username (no pw) defined
View: 18454
Assigned To: Nosy List: berker.peksag, eric.araujo, geoffreyspear, tarek
Priority: low Keywords:

Created on 2009-02-08 21:27 by tarek, last changed 2016-05-21 14:52 by berker.peksag. This issue is now closed.

Messages (5)
msg81420 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-02-08 21:27
finalize_option in upload command should ask for the password, if not
given by pypirc or by a previous register command.
msg113391 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-08-09 06:37
Hm, doing user interaction in finalize_options seems strange to me, but if we do it in run only other commands (upload_docs in d2) would not be able to get the options (although I’m not sure at all, since the index commands have strange command-line parsing).

Can such a feature request land in distutils too after being tested in distutils2?
msg113394 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2010-08-09 07:22
no, distutils is feature frozen
msg213464 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2014-03-13 20:38
Freeze was lifted.  The user experience for register/upload isn’t as good as it could be, I think we could improve it.
msg266003 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-05-21 14:52
Issue 18454 is a duplicate of this, but I'm going to close this one (there are patches for 2.7 and 3.5 in issue 18454).
History
Date User Action Args
2016-05-21 14:52:40berker.peksagsetstatus: open -> closed

superseder: distutils crashes when uploading to PyPI having only the username (no pw) defined

nosy: + berker.peksag
messages: + msg266003
resolution: duplicate
stage: needs patch -> resolved
2015-02-01 13:44:54geoffreyspearsetnosy: + geoffreyspear
2014-03-13 20:38:36eric.araujosetassignee: tarek ->
messages: + msg213464
components: + Distutils, - Distutils2
versions: + Python 2.7, Python 3.3, Python 3.4, - 3rd party
2010-09-29 23:48:10eric.araujosetversions: + 3rd party, - Python 2.6, Python 2.5, Python 3.1, Python 2.7, Python 3.2
2010-08-09 07:22:57tareksetmessages: + msg113394
2010-08-09 06:37:56eric.araujosetnosy: tarek, eric.araujo
stage: needs patch
components: + Distutils2, - Distutils
versions: + Python 2.6, Python 2.5, Python 3.1, Python 2.7
2010-08-09 06:37:19eric.araujosetmessages: + msg113391
2010-08-09 04:38:06terry.reedysetversions: + Python 3.2, - Python 3.1, Python 2.7
2010-04-08 23:59:26eric.araujosetnosy: + eric.araujo
2009-02-08 21:27:47tarekcreate