classification
Title: Error in atexit._run_exitfuncs [...] Exception expected for value, tuple found
Type: behavior Stage:
Components: Tests Versions: Python 3.1
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, mark.dickinson
Priority: normal Keywords:

Created on 2009-01-28 12:52 by mark.dickinson, last changed 2010-07-09 13:20 by mark.dickinson. This issue is now closed.

Messages (3)
msg80705 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2009-01-28 12:52
When running the test-suite (using "make test") for a 32-bit debug build 
of py3k on OS X 10.5/Core 2 Duo, I occasionally (perhaps 1 time in 10) get 
the following output at the end of a (successful) test_run:

...
test_zipimport_support
test_zlib
301 tests OK.
22 tests skipped:
    test_codecmaps_cn test_codecmaps_hk test_codecmaps_jp
    test_codecmaps_kr test_codecmaps_tw test_curses test_dbm_gnu
    test_epoll test_largefile test_nis test_normalization
    test_ossaudiodev test_pep277 test_socketserver test_startfile
    test_timeout test_urllib2net test_urllibnet test_winreg
    test_winsound test_xmlrpc_net test_zipfile64
Those skips are all expected on darwin.
Error in atexit._run_exitfuncs:
TypeError: print_exception(): Exception expected for value, tuple found
[1264638 refs]


I assume that there's a genuine exception here that we're not seeing;  
i.e., that there's a shallow error (tuple instead of exception) that's 
masking output of information from a deeper error.
msg109728 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-07-09 13:11
Can this be reproduced with 3.1, 3.2 or even 2.7, or can it be closed?
msg109730 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2010-07-09 13:20
I haven't seen this for a while;  it can probably be closed.  Thanks!
History
Date User Action Args
2010-07-09 13:20:47mark.dickinsonsetstatus: open -> closed
resolution: works for me
messages: + msg109730
2010-07-09 13:11:01BreamoreBoysetnosy: + BreamoreBoy
messages: + msg109728
2009-01-28 12:52:47mark.dickinsoncreate