classification
Title: Failures in test_xmlrpc
Type: crash Stage:
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, kristjan.jonsson, pitrou, vstinner
Priority: critical Keywords:

Created on 2009-01-13 23:22 by pitrou, last changed 2009-01-14 00:14 by kristjan.jonsson. This issue is now closed.

Messages (10)
msg79792 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-01-13 23:22
This is witnessed on trunk, at home as well as on the buildbots:

======================================================================
ERROR: test_dotted_attribute (test.test_xmlrpc.SimpleServerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/antoine/cpython/__svn__/Lib/test/test_xmlrpc.py", line
492, in test_dotted_attribute
    self.test_simple1()
  File "/home/antoine/cpython/__svn__/Lib/test/test_xmlrpc.py", line
376, in test_simple1
    self.assertEqual(p.pow(6,8), 6**8)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1199, in
__call__
    return self.__send(self.__name, args)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1465, in
__request
    verbose=self.__verbose
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1248, in
request
    return self._parse_response(h.getfile())
AttributeError: Transport instance has no attribute '_parse_response'

======================================================================
ERROR: test_introspection1 (test.test_xmlrpc.SimpleServerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/antoine/cpython/__svn__/Lib/test/test_xmlrpc.py", line
398, in test_introspection1
    meth = p.system.listMethods()
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1199, in
__call__
    return self.__send(self.__name, args)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1465, in
__request
    verbose=self.__verbose
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1248, in
request
    return self._parse_response(h.getfile())
AttributeError: Transport instance has no attribute '_parse_response'

======================================================================
ERROR: test_introspection2 (test.test_xmlrpc.SimpleServerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/antoine/cpython/__svn__/Lib/test/test_xmlrpc.py", line
413, in test_introspection2
    divhelp = p.system.methodHelp('div')
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1199, in
__call__
    return self.__send(self.__name, args)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1465, in
__request
    verbose=self.__verbose
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1248, in
request
    return self._parse_response(h.getfile())
AttributeError: Transport instance has no attribute '_parse_response'

======================================================================
ERROR: test_introspection3 (test.test_xmlrpc.SimpleServerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/antoine/cpython/__svn__/Lib/test/test_xmlrpc.py", line
425, in test_introspection3
    myfunction = p.system.methodHelp('my_function')
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1199, in
__call__
    return self.__send(self.__name, args)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1465, in
__request
    verbose=self.__verbose
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1248, in
request
    return self._parse_response(h.getfile())
AttributeError: Transport instance has no attribute '_parse_response'

======================================================================
ERROR: test_introspection4 (test.test_xmlrpc.SimpleServerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/antoine/cpython/__svn__/Lib/test/test_xmlrpc.py", line
438, in test_introspection4
    divsig = p.system.methodSignature('div')
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1199, in
__call__
    return self.__send(self.__name, args)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1465, in
__request
    verbose=self.__verbose
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1248, in
request
    return self._parse_response(h.getfile())
AttributeError: Transport instance has no attribute '_parse_response'

======================================================================
ERROR: test_multicall (test.test_xmlrpc.SimpleServerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/antoine/cpython/__svn__/Lib/test/test_xmlrpc.py", line
453, in test_multicall
    add_result, pow_result, div_result = multicall()
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1042, in
__call__
    return
MultiCallIterator(self.__server.system.multicall(marshalled_list))
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1199, in
__call__
    return self.__send(self.__name, args)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1465, in
__request
    verbose=self.__verbose
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1248, in
request
    return self._parse_response(h.getfile())
AttributeError: Transport instance has no attribute '_parse_response'

======================================================================
ERROR: test_non_existing_multicall (test.test_xmlrpc.SimpleServerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/antoine/cpython/__svn__/Lib/test/test_xmlrpc.py", line
468, in test_non_existing_multicall
    result = multicall()
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1042, in
__call__
    return
MultiCallIterator(self.__server.system.multicall(marshalled_list))
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1199, in
__call__
    return self.__send(self.__name, args)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1465, in
__request
    verbose=self.__verbose
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1248, in
request
    return self._parse_response(h.getfile())
AttributeError: Transport instance has no attribute '_parse_response'

======================================================================
ERROR: test_simple1 (test.test_xmlrpc.SimpleServerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/antoine/cpython/__svn__/Lib/test/test_xmlrpc.py", line
376, in test_simple1
    self.assertEqual(p.pow(6,8), 6**8)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1199, in
__call__
    return self.__send(self.__name, args)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1465, in
__request
    verbose=self.__verbose
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1248, in
request
    return self._parse_response(h.getfile())
AttributeError: Transport instance has no attribute '_parse_response'

======================================================================
ERROR: test_basic (test.test_xmlrpc.FailingServerTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/antoine/cpython/__svn__/Lib/test/test_xmlrpc.py", line
534, in test_basic
    self.assertEqual(p.pow(6,8), 6**8)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1199, in
__call__
    return self.__send(self.__name, args)
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1465, in
__request
    verbose=self.__verbose
  File "/home/antoine/cpython/__svn__/Lib/xmlrpclib.py", line 1248, in
request
    return self._parse_response(h.getfile())
AttributeError: Transport instance has no attribute '_parse_response'

----------------------------------------------------------------------
msg79800 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2009-01-13 23:36
Regression introduced by r68532. Replace self._parse_response() by 
self.parse_response() fixes the tests.
msg79802 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2009-01-13 23:38
r68532 was a fix for the issue #4879 and removed an old compatibility 
interface (_parse_response).
msg79805 - (view) Author: Kristján Valur Jónsson (kristjan.jonsson) * (Python committer) Date: 2009-01-13 23:45
Oh dear, this is because it skips those tests on windows.  I'll check 
in a fix to xmlrpclib.py
msg79807 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2009-01-13 23:48
Fixed in r68597.
msg79808 - (view) Author: Kristján Valur Jónsson (kristjan.jonsson) * (Python committer) Date: 2009-01-13 23:52
Ok, you beat me to it.
So, is there any good reason to keep those xmlrpc tests defunct on 
win32 still?
msg79809 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2009-01-13 23:55
On Tue, Jan 13, 2009 at 5:52 PM, Kristján Valur Jónsson
<report@bugs.python.org> wrote:
>
> Kristján Valur Jónsson <kristjan@ccpgames.com> added the comment:
>
> Ok, you beat me to it.

Sorry, I just seem to have bad timing today. :)

> So, is there any good reason to keep those xmlrpc tests defunct on
> win32 still?

I'm not sure. Have you tried enabling them?
msg79811 - (view) Author: Kristján Valur Jónsson (kristjan.jonsson) * (Python committer) Date: 2009-01-14 00:11
Yes and they work, but do take some 10 seconds to run.  If it is 
similar on unix, I'll do so.  What's your numbers?
msg79812 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2009-01-14 00:12
On Tue, Jan 13, 2009 at 6:11 PM, Kristján Valur Jónsson
<report@bugs.python.org> wrote:
>
> Kristján Valur Jónsson <kristjan@ccpgames.com> added the comment:
>
> Yes and they work, but do take some 10 seconds to run.  If it is
> similar on unix, I'll do so.  What's your numbers?

It takes about a second to run them here.
msg79813 - (view) Author: Kristján Valur Jónsson (kristjan.jonsson) * (Python committer) Date: 2009-01-14 00:14
Ok, I'll keep them disabled until I figure out why they take so long.  
Maybe there is some performance enhancements yet to be made :)
History
Date User Action Args
2009-01-14 00:14:12kristjan.jonssonsetmessages: + msg79813
2009-01-14 00:12:48benjamin.petersonsetmessages: + msg79812
2009-01-14 00:11:41kristjan.jonssonsetmessages: + msg79811
2009-01-13 23:55:22benjamin.petersonsetmessages: + msg79809
2009-01-13 23:52:41kristjan.jonssonsetmessages: + msg79808
2009-01-13 23:48:55benjamin.petersonsetstatus: open -> closed
resolution: fixed
messages: + msg79807
nosy: + benjamin.peterson
2009-01-13 23:45:35kristjan.jonssonsetmessages: + msg79805
2009-01-13 23:38:56vstinnersetmessages: + msg79802
2009-01-13 23:36:27vstinnersetnosy: + vstinner
messages: + msg79800
2009-01-13 23:29:09pitrousetnosy: + kristjan.jonsson
2009-01-13 23:22:35pitroucreate