classification
Title: regrtest.py -u largefile test_io fails on OS X 10.5.6
Type: crash Stage:
Components: Tests Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ironsmith, pitrou
Priority: normal Keywords:

Created on 2009-01-04 11:25 by ironsmith, last changed 2009-01-04 17:38 by pitrou. This issue is now closed.

Messages (3)
msg79044 - (view) Author: Cem Karan (ironsmith) Date: 2009-01-04 11:25
I'm running OS X 10.5.6 (uname -a == Darwin 9.6.0 Darwin Kernel Version 9.6.0: Mon Nov 
24 17:37:00 PST 2008; root:xnu-1228.9.59~1/RELEASE_I386 i386) I get the following 
error after compiling Python 3.0.  Note that I have NOT installed it; I'm just trying 
to run the regression tests on the build.

Python-3.0 cfkaran2$ ./Lib/test/regrtest.py -u largefile test_io
  File "./Lib/test/regrtest.py", line 183
    print(msg, file=sys.stderr)
                   ^
SyntaxError: invalid syntax

I suspect that tester is not using the newly built python 3.0, but is using whatever 
is installed on the system, though I have not checked this at all.
msg79067 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-01-04 15:38
Well, you must indeed use the newly built python, that is "./python -m
test.regrtest [any arguments]".

Out of curiosity, why did you specifically run test_io? Any problem on
your platform?
msg79071 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-01-04 17:38
> Do you know how to get python to  
> run from the locally built directory without installing it?

Well, precisely as I told you, but unfortunately it seems it doesn't
work for you.
I'm no Mac OS X user, so I advise you search the tracker for similar
problems, it seems the build procedure on Mac hasn't been polished yet
for Python 3.0.

(in any case, you can't run Python 3.0 scripts with Python 2.x, because
there have been a few syntax changes)
History
Date User Action Args
2009-01-04 17:38:26pitrousetmessages: + msg79071
2009-01-04 15:38:34pitrousetstatus: open -> closed
resolution: not a bug
messages: + msg79067
nosy: + pitrou
2009-01-04 11:25:37ironsmithcreate