classification
Title: doc issue for threading module (name/daemon properties)
Type: Stage:
Components: Documentation Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: cgoldberg, georg.brandl
Priority: normal Keywords:

Created on 2009-01-02 14:55 by cgoldberg, last changed 2009-01-02 20:10 by georg.brandl. This issue is now closed.

Messages (7)
msg78807 - (view) Author: Corey Goldberg (cgoldberg) Date: 2009-01-02 14:55
In the current 3.0 doc for threading:
http://docs.python.org/dev/py3k/library/threading.htm

it says:

Thread.getName()
Thread.setName()
  Old API for name.
  
and

Thread.isDaemon()
Thread.setDaemon()
  Old API for daemon.
  
  
'name' and 'daemon' properties should be listed as defaults and the old
getter/setter methods should be noted as "Old API".
msg78859 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2009-01-02 19:09
I don't understand -- both name and daemon are already documented on
their own.
msg78860 - (view) Author: Corey Goldberg (cgoldberg) Date: 2009-01-02 19:19
sorry for the confusion.  The doc might actually be correct, but it
seems ambiguous and confusing with respect to the name and daemon
properties.


if you look here:
http://docs.python.org/dev/py3k/library/threading.html

scroll down to where it says:

Thread.getName()
Thread.setName()
    Old API for name.

when you click on "name", it expands and shows you the 'name' property.
 However, it looks like it is denoting this as the "Old API".

at first glance it appears as though Thread.getName() and
Thread.setName() are the new way, and you can click on 'name' to see the
old API.  

I think the issue is actually the fact that Thread.name and
Thread.daemon are not expanded in the HTML doc until you click on their
names (unlike other properties/attributes in the doc which are already
expanded)

Let me know if I am not explaining well.
msg78861 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2009-01-02 19:24
Hmm, I do see docs for name and daemon, directly below the respective
getter/setter entries.

For more clarity, I can only offer moving the getter/setter entries
below the property entries.
msg78862 - (view) Author: Corey Goldberg (cgoldberg) Date: 2009-01-02 19:25
Just took another look.  The doc is correct and already shows name and
daemon properties.

it was just confusing at first since where it says "Old API for name",
it links to the new style API and you jump to that section.

perhaps it could be stated more clearly?  If this is just a nit, please
close this issue.
msg78863 - (view) Author: Corey Goldberg (cgoldberg) Date: 2009-01-02 19:26
yes if the new style was listed first, and the old style was below and
marked as "Old API", it would help with some confusion (like I ran into).
msg78865 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2009-01-02 20:10
OK, moved the old methods below the new properties in r68170.
History
Date User Action Args
2009-01-02 20:10:29georg.brandlsetstatus: open -> closed
resolution: fixed
messages: + msg78865
2009-01-02 19:26:57cgoldbergsetmessages: + msg78863
2009-01-02 19:25:04cgoldbergsetmessages: + msg78862
2009-01-02 19:24:11georg.brandlsetmessages: + msg78861
2009-01-02 19:19:08cgoldbergsetmessages: + msg78860
2009-01-02 19:09:34georg.brandlsetmessages: + msg78859
2009-01-02 14:55:12cgoldbergcreate