classification
Title: pythonw.exe crash in GUI application(PythonWX)
Type: crash Stage:
Components: Versions: 3rd party
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: george, loewis
Priority: normal Keywords:

Created on 2008-12-22 15:02 by george, last changed 2008-12-22 15:11 by loewis. This issue is now closed.

Files
File name Uploaded Description Edit
simple editor.pyw george, 2008-12-22 15:02 Another example
Messages (2)
msg78189 - (view) Author: George (george) Date: 2008-12-22 15:02
I have Python 2.6.1 in Windows Vista. It happened in Python 2.6 and I 
hoped it would be fixed. I don't know what happenes in other versions. 
When I open a file containing a python program(".py"/".pyw" and even 
one compiled with py2exe) made by using the PythonWX GUI programming 
libraries it crashes immediately after the mouse hovers over the window 
created by the program(spesifically in the area inside it). It happenes 
both when the program is a ".py" file and a ".pyw" file or one compiled 
with py2exe. I get a message that the program stopped working. 
Shouldn'nt I get a message about wrong code? It doesn't crash in the 
Python Shell, but it has happened ,too, a few times.

Do I do something wrong?
Is there something I should know?

The programs I use are not made by me(I can't yet make mine), but they 
are examples downloaded or copy-pasted. Here is one:

import wx
app = wx.PySimpleApp()
frame = wx.Frame(None,-1,"Hello World")
frame.Show(True)
app.MainLoop()

Please tell me what is wrong or what I should do.
msg78191 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-12-22 15:11
Please understand that the bug tracker is not a place to obtain help,
but a place to provide help. You can help by analysing the source of the
crash in a debugger, such as the one of Visual Studio.

In any case, it seems that the crash is specific to wxPython, which is
not part of the Python 2.6 distribution. Please report it to the authors
of wxPython.

Closing this report as 3rd-party.
History
Date User Action Args
2008-12-22 15:11:15loewissetstatus: open -> closed
resolution: not a bug
messages: + msg78191
nosy: + loewis
versions: + 3rd party, - Python 2.6
2008-12-22 15:04:10georgesettitle: pythonw.exe crash in GU application(PythonWX) -> pythonw.exe crash in GUI application(PythonWX)
2008-12-22 15:02:19georgecreate