classification
Title: Write 'Using Python on Platform X' documents
Type: enhancement Stage:
Components: Documentation Versions:
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: akuchling, anthonybaxter, fdrake, georg.brandl
Priority: normal Keywords:

Created on 2001-10-10 06:28 by anthonybaxter, last changed 2007-12-04 18:12 by georg.brandl. This issue is now closed.

Messages (9)
msg6885 - (view) Author: Anthony Baxter (anthonybaxter) (Python triager) Date: 2001-10-10 06:28
Some stuff that's in the man page (e.g. the 
syntax for the -W switch) doesn't appear to
be in the HTML documentation. If it is there, 
it's _very_ well hidden away.
msg6886 - (view) Author: Fred Drake (fdrake) (Python committer) Date: 2001-10-25 02:12
Logged In: YES 
user_id=3066

I agree.

Where would you suggest the information be added?
msg6887 - (view) Author: Anthony Baxter (anthonybaxter) (Python triager) Date: 2001-10-25 06:17
Logged In: YES 
user_id=29957

See, that's the problem :) It's not clear where this
might go - it's almost a "Using Python" section, which,
as far as I can see, doesn't really exist. 

This might also include stuff about the Windows GUI and
other interfaces for using python.

If a shorter-term "just get the -W stuff in" approach is
wanted, then extended the lib/module-warnings might be the
approach... but it really does seem like it needs to be
somewhere central. 
msg6888 - (view) Author: Fred Drake (fdrake) (Python committer) Date: 2004-11-11 06:33
Logged In: YES 
user_id=3066

I'll note that the "Macintosh Library Modules" document
deals with this sort of issue for the Mac (though it may be
out of date for Mac OS X; not sure).  The first chapter is
an introduction to using Python on the Mac, and the
remaining chapters provide module reference documentation.

What's needed is something like the first chapter of that
for Unix and Windows.  I'm not sure where it should go,
though; I don't want that material in the main library
reference.

This almost makes me want three platform-specific documents,
one for Windows, one for Unix, and the existing Mac OS
document, each containing the relevant "Using Python on ..."
chapter, followed by chapters containing platform-specific
modules.  Modules that apply to two or more of the platforms
would continue to be documented in the main library
reference.  The distutils modules are already documented in
the distutils documentation as well.  This should be fine
since the "global" module index is the normal general entry
point anyway.
msg6889 - (view) Author: Anthony Baxter (anthonybaxter) (Python triager) Date: 2004-11-11 07:27
Logged In: YES 
user_id=29957

What about instead a new "Using Python" document. There's a
bunch of overlap between the platforms. We can then also
have separate chapters for Mac, Win, Unix. I think trying to
produce platform specific docs is going to be a headache in
the long run.
msg6890 - (view) Author: A.M. Kuchling (akuchling) * (Python committer) Date: 2006-12-21 14:50
Changing summary to be more accurate.
msg55186 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-08-23 19:15
See issue223599 (which I closed as duplicate of this) for a few specific
Windows questions.
msg57982 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-11-30 13:57
This will hopefully be done in GHOP.
msg58199 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-12-04 18:12
Okay, now we have documents for Unix, Windows and Mac!
History
Date User Action Args
2007-12-04 18:12:55georg.brandlsetstatus: pending -> closed
messages: + msg58199
2007-11-30 13:57:13georg.brandlsetstatus: open -> pending
assignee: georg.brandl
messages: + msg57982
2007-08-23 19:15:44georg.brandllinkissue223599 superseder
2007-08-23 19:15:18georg.brandlsetnosy: + georg.brandl
messages: + msg55186
2007-08-23 18:05:32fdrakesetassignee: fdrake -> (no value)
2001-10-10 06:28:40anthonybaxtercreate