classification
Title: Can not import readline on python3.0 (ubuntu 8.04)
Type: behavior Stage:
Components: Installation Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, xxiao
Priority: normal Keywords:

Created on 2008-12-11 02:45 by xxiao, last changed 2008-12-11 02:59 by benjamin.peterson. This issue is now closed.

Messages (3)
msg77585 - (view) Author: X Xiao (xxiao) Date: 2008-12-11 02:45
I can "import readline" just fine on AMD64 ubuntu 8.04 under python3.0,
however on 32-bit ubuntu 8.04 I could not "import readline" for
python3.0. It says 
"import readline
ImportError: No module named readline". I made sure both ubuntu machines
have readline installed correctly, python2.x runs well and can import
readline without any issues.
msg77586 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-12-11 02:47
Did you build Python yourself? If so, can you paste the last lines of
the build process like this:

Failed to find the necessary bits to build these modules:
bsddb185           gdbm               linuxaudiodev   
ossaudiodev        spwd               sunaudiodev     
To find the necessary bits, look in setup.py in detect_modules() for the
module's name.

running build_scripts
msg77587 - (view) Author: X Xiao (xxiao) Date: 2008-12-11 02:59
I just rebuild it again, it went away. not sure what I did wrong at
first try.

The last few lines during compilation are:
INFO: Can't locate Tcl/Tk libs and/or headers

Failed to find the necessary bits to build these modules:
_dbm               _sqlite3           _tkinter        
To find the necessary bits, look in setup.py in detect_modules() for the
module's name.

Looks like I need install python-sqlite etc.
History
Date User Action Args
2008-12-11 02:59:43benjamin.petersonsetstatus: open -> closed
resolution: not a bug
2008-12-11 02:59:01xxiaosetmessages: + msg77587
2008-12-11 02:47:50benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg77586
2008-12-11 02:45:13xxiaocreate