classification
Title: 3.0 documentation mentions using maketrans from within the string module.
Type: Stage:
Components: Documentation Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: benjamin.peterson, georg.brandl, suicideducky
Priority: normal Keywords:

Created on 2008-12-09 00:30 by suicideducky, last changed 2008-12-13 03:03 by benjamin.peterson. This issue is now closed.

Messages (2)
msg77379 - (view) Author: chris (suicideducky) Date: 2008-12-09 00:30
http://docs.python.org/3.0/library/stdtypes.html#str.translate
mentions the following:
"You can use the maketrans() helper function in the string module to 
create a translation table."

But maketrans is now a string method not just a function of the string 
module. It even mentions that right above it that it is now a method of 
string objects:
"A map for translate() is usually best created by str.maketrans()."

The page where this all appears in is:
http://docs.python.org/3.0/library/stdtypes.html

It may have just not been updated fully from an older release.
If I am mistaken and this is not a bug, I appologise.
msg77713 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-12-13 03:03
Thanks for the report! Fixed in r67724.
History
Date User Action Args
2008-12-13 03:03:59benjamin.petersonsetstatus: open -> closed
resolution: fixed
messages: + msg77713
nosy: + benjamin.peterson
2008-12-09 00:30:28suicideduckycreate