classification
Title: Conflicting statements in docs about default support for asyncio subprocesses on Windows
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.11, Python 3.10, Python 3.9
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Rob4226, asvetlov, docs@python, miss-islington, yselivanov
Priority: normal Keywords: patch

Created on 2021-11-24 22:15 by Rob4226, last changed 2021-12-01 15:44 by asvetlov. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 29857 merged Rob4226, 2021-11-30 01:03
PR 29877 merged miss-islington, 2021-12-01 12:25
PR 29878 merged miss-islington, 2021-12-01 12:25
Messages (6)
msg406967 - (view) Author: Rob (Rob4226) * Date: 2021-11-24 22:15
Hi,

In the docs for the asyncio event loop, it has a note on page:
https://docs.python.org/3/library/asyncio-eventloop.html#running-subprocesses

"Note The default asyncio event loop on Windows does not support subprocesses. See Subprocess Support on Windows for details."

Then following the link in that note to:
https://docs.python.org/3/library/asyncio-platforms.html#subprocess-support-on-windows
Says:
"On Windows, the default event loop ProactorEventLoop supports subprocesses, whereas SelectorEventLoop does not."

So the issue is, there are conflicting statements about default support for asyncio subprocesses on Windows. It seems the first statement listed above, is wrong or outdated since the default event loop on Windows is the ProactorEventLoop which does support subprocesses.

Thank you!
msg406975 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2021-11-25 07:19
You are correct, the first statement is outdated.

Please feel free to make a pull request.
msg406976 - (view) Author: Rob (Rob4226) * Date: 2021-11-25 07:21
Ok will do. Thanks for confirming.
msg407449 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2021-12-01 12:24
New changeset f27bef30438d2f07f19de91e021f34b77ccc4b20 by Rob in branch 'main':
bpo-45896: Fix docs default asyncio event loop on Windows (GH-29857)
https://github.com/python/cpython/commit/f27bef30438d2f07f19de91e021f34b77ccc4b20
msg407460 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2021-12-01 15:40
New changeset 4203a5d1918ca874e305806b787e3c8c6fc35e3e by Miss Islington (bot) in branch '3.9':
bpo-45896: Fix docs default asyncio event loop on Windows (GH-29857) (GH-29878)
https://github.com/python/cpython/commit/4203a5d1918ca874e305806b787e3c8c6fc35e3e
msg407462 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2021-12-01 15:44
New changeset e99c5e039b380199843db4e06974883d9f3ddad0 by Miss Islington (bot) in branch '3.10':
bpo-45896: Fix docs default asyncio event loop on Windows (GH-29857) (GH-29877)
https://github.com/python/cpython/commit/e99c5e039b380199843db4e06974883d9f3ddad0
History
Date User Action Args
2021-12-01 15:44:36asvetlovsetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2021-12-01 15:44:18asvetlovsetmessages: + msg407462
2021-12-01 15:40:58asvetlovsetmessages: + msg407460
2021-12-01 12:25:21miss-islingtonsetpull_requests: + pull_request28103
2021-12-01 12:25:16miss-islingtonsetnosy: + miss-islington
pull_requests: + pull_request28102
2021-12-01 12:24:54asvetlovsetmessages: + msg407449
2021-11-30 01:03:09Rob4226setkeywords: + patch
stage: patch review
pull_requests: + pull_request28085
2021-11-25 07:21:39Rob4226setmessages: + msg406976
2021-11-25 07:19:56asvetlovsetmessages: + msg406975
2021-11-25 01:23:43AlexWaygoodsetnosy: + asvetlov, yselivanov

type: behavior
versions: + Python 3.9, Python 3.11
2021-11-24 22:15:22Rob4226create