classification
Title: Small oversight in 3.11 gzip.decompress implementation with regards to backwards compatibility
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.11
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: lukasz.langa, rhpvorderman
Priority: normal Keywords: patch

Created on 2021-10-18 08:51 by rhpvorderman, last changed 2021-11-19 18:44 by lukasz.langa. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 29023 closed rhpvorderman, 2021-10-18 08:52
PR 29029 merged rhpvorderman, 2021-10-18 12:01
Messages (5)
msg404165 - (view) Author: Ruben Vorderman (rhpvorderman) * Date: 2021-10-18 08:51
A 'struct.error: unpack requires a buffer of 8 bytes' is thrown when a gzip trailer is truncated instead of an EOFError such as in the 3.10 and prior releases.
msg404169 - (view) Author: Ruben Vorderman (rhpvorderman) * Date: 2021-10-18 09:45
It turns out there is a bug where FNAME and/or FCOMMENT flags are set in the header, but no error is thrown when NAME and COMMENT fields are missing.
msg405782 - (view) Author: Ruben Vorderman (rhpvorderman) * Date: 2021-11-05 10:36
bump. This is a regression introduced by https://github.com/python/cpython/pull/27941
msg406603 - (view) Author: Łukasz Langa (lukasz.langa) * (Python committer) Date: 2021-11-19 18:07
New changeset 0ff3d95b9875805ac03aeffc37ae4458ce3b8ac0 by Ruben Vorderman in branch 'main':
bpo-45507: EOFErrors should be thrown for truncated gzip members (GH-29029)
https://github.com/python/cpython/commit/0ff3d95b9875805ac03aeffc37ae4458ce3b8ac0
msg406608 - (view) Author: Łukasz Langa (lukasz.langa) * (Python committer) Date: 2021-11-19 18:44
Thanks for noticing, Ruben! ✨ 🍰 ✨
History
Date User Action Args
2021-11-19 18:44:42lukasz.langasetstatus: open -> closed
resolution: fixed
messages: + msg406608

stage: patch review -> resolved
2021-11-19 18:07:15lukasz.langasetnosy: + lukasz.langa
messages: + msg406603
2021-11-05 10:36:57rhpvordermansetmessages: + msg405782
2021-10-18 12:01:32rhpvordermansetpull_requests: + pull_request27301
2021-10-18 09:45:06rhpvordermansetmessages: + msg404169
2021-10-18 08:52:16rhpvordermansetkeywords: + patch
stage: patch review
pull_requests: + pull_request27296
2021-10-18 08:51:32rhpvordermancreate