classification
Title: test_sysconfig: test_user_similar() fails if sys.platlibdir is 'lib64'
Type: Stage: resolved
Components: Tests Versions: Python 3.11, Python 3.10
process
Status: closed Resolution: duplicate
Dependencies: Superseder: sysconfig's posix_user scheme has different platlib value to distutils's unix_user
View: 44860
Assigned To: Nosy List: dstufft, eric.araujo, frenzy, hroncok, lukasz.langa, miss-islington, pablogsal, petr.viktorin, uranusjr, vstinner
Priority: release blocker Keywords:

Created on 2021-09-08 10:46 by vstinner, last changed 2021-09-09 09:54 by vstinner. This issue is now closed.

Messages (7)
msg401372 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-09-08 10:46
When Python is configured to use 'lib64' for sys.platlibdir, test_sysconfig fails:

$ ./configure --with-platlibdir=lib64
$ make
$ ./python -m test -v test_sysconfig 

======================================================================
FAIL: test_user_similar (test.test_sysconfig.TestSysConfig)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/vstinner/python/main/Lib/test/test_sysconfig.py", line 299, in test_user_similar
    self.assertEqual(user_path, global_path.replace(base, user, 1))
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
AssertionError: '/home/vstinner/.local/lib/python3.11/site-packages' != '/home/vstinner/.local/lib64/python3.11/site-packages'
- /home/vstinner/.local/lib/python3.11/site-packages
+ /home/vstinner/.local/lib64/python3.11/site-packages
?                          ++
msg401374 - (view) Author: Miro Hrončok (hroncok) * Date: 2021-09-08 10:48
This was introduced in issue44860.
msg401375 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-09-08 10:54
> This was introduced in issue44860.

Right. Reverting the commit 608a6292366ebba20f33d93d8b52cbb928429e47 (bpo-44860) fix the test.

The test should be updated.
msg401376 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-09-08 10:57
I mark this issue as a release blocker: it would be *nice* to fix it before Python 3.10.0 final ;-)
msg401416 - (view) Author: Miro Hrončok (hroncok) * Date: 2021-09-08 17:33
Fix was proposed in https://github.com/python/cpython/pull/28235 but references the original bpi number.
msg401449 - (view) Author: Miro Hrončok (hroncok) * Date: 2021-09-09 09:13
The 3.10 backport is in https://github.com/python/cpython/pull/28251
msg401454 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-09-09 09:54
I mark this issue as a duplicate of bpo-44860.
History
Date User Action Args
2021-09-09 09:54:05vstinnersetstatus: open -> closed
superseder: sysconfig's posix_user scheme has different platlib value to distutils's unix_user
messages: + msg401454

resolution: duplicate
stage: resolved
2021-09-09 09:13:10hroncoksetmessages: + msg401449
2021-09-08 17:33:33hroncoksetmessages: + msg401416
2021-09-08 10:57:00vstinnersetpriority: normal -> release blocker

messages: + msg401376
2021-09-08 10:54:39vstinnersetmessages: + msg401375
2021-09-08 10:48:10hroncoksetnosy: + eric.araujo, petr.viktorin, lukasz.langa, dstufft, uranusjr, hroncok, frenzy, pablogsal, miss-islington
messages: + msg401374
2021-09-08 10:46:29vstinnercreate