This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: Docs fail to build - looking for the wrong interpreter (Python 3.10-rc1)
Type: Stage: resolved
Components: Documentation Versions: Python 3.10
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, ksurma, pablogsal, xtreak
Priority: normal Keywords:

Created on 2021-08-04 08:39 by ksurma, last changed 2022-04-11 14:59 by admin. This issue is now closed.

Messages (5)
msg398866 - (view) Author: Karolina Surma (ksurma) * Date: 2021-08-04 08:39
Documentation for Python3.10-rc1 fails to build.
sphinx-build looks for non-existing interpreter, which causes a crash.
Looking at the tarball with Python, there is Doc/venv/ present (which probably shouldn't be included) containing executable sphinx-build with shebang " #!/home/pablogsal/github/python/3.10/3.10.0rc1/Python-3.10.0rc1/Doc/venv/bin/python3".

Traceback from our Fedora RPM build:

+ make -C Doc html PYTHON=/usr/bin/python3
make: Entering directory '/builddir/build/BUILD/Python-3.10.0rc1/Doc'
venv already exists
mkdir -p build
Using existing Misc/NEWS file
PATH=./venv/bin:$PATH sphinx-build -b html -d build/doctrees   -W . build/html 
/bin/sh: ./venv/bin/sphinx-build: /home/pablogsal/github/python/3.10/3.10.0rc1/Python-3.10.0rc1/Doc/venv/bin/python3: bad interpreter: No such file or directory
make: Leaving directory '/builddir/build/BUILD/Python-3.10.0rc1/Doc'
make: *** [Makefile:51: build] Error 126
msg398871 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2021-08-04 09:04
Seems like a duplicate of https://bugs.python.org/issue44824
msg398877 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2021-08-04 09:32
I will look into this ASAP
msg398882 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2021-08-04 10:12
The tarball in the download server has been updated to not contain the venv directory and the release machinery has been updated to account for https://bugs.python.org/issue44756
msg398883 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2021-08-04 10:12
Note, this problem was created due to:

https://bugs.python.org/issue44756
History
Date User Action Args
2022-04-11 14:59:48adminsetgithub: 88986
2021-08-04 10:17:48pablogsalsetstatus: open -> closed
resolution: fixed
stage: resolved
2021-08-04 10:12:42pablogsalsetmessages: + msg398883
2021-08-04 10:12:25pablogsalsetmessages: + msg398882
2021-08-04 09:32:31pablogsalsetmessages: + msg398877
2021-08-04 09:04:19xtreaksetnosy: + xtreak, pablogsal
messages: + msg398871
2021-08-04 08:39:24ksurmacreate