classification
Title: Move test_futures files*.py into a subdirectory of Lib/test
Type: enhancement Stage: resolved
Components: Library (Lib), Tests Versions: Python 3.11
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Leonardofreua, iritkatriel
Priority: normal Keywords:

Created on 2021-07-15 20:39 by Leonardofreua, last changed 2021-07-16 13:40 by iritkatriel. This issue is now closed.

Messages (5)
msg397581 - (view) Author: Leonardo Freua (Leonardofreua) * Date: 2021-07-15 20:39
There are currently 6 files referring to __future__ tests, these are in the root directory Lib/test.

It would be interesting to move them to a directory called Lib/test/test_future.

This change could contribute to the organization of the tests that have already been discussed in other issues (e.g https://bugs.python.org/issue15907).

I wait for the ok to send the PR.
msg397582 - (view) Author: Leonardo Freua (Leonardofreua) * Date: 2021-07-15 20:44
List of files:

test_future.py
test_future3.py
test_future4.py
test_future5.py

Obs.: In fact there are 5 files, since the number 2 doesn't exist.
msg397614 - (view) Author: Irit Katriel (iritkatriel) * (Python committer) Date: 2021-07-16 11:27
This kind of reorg was recently rejected in issue44573.
msg397622 - (view) Author: Leonardo Freua (Leonardofreua) * Date: 2021-07-16 13:26
Definitely not the same kind of reorganization! In issue44573 what was proposed was the reorganization of the data files used in the tests.

And what I'm proposing now is equivalent to what was proposed in issue15907 (and there it was accepted, there is even an open PR awaiting review.)
msg397627 - (view) Author: Irit Katriel (iritkatriel) * (Python committer) Date: 2021-07-16 13:40
A patch awaiting review since 2012 is not exactly the same as "the issue was accepted".
History
Date User Action Args
2021-07-16 13:40:41iritkatrielsetmessages: + msg397627
2021-07-16 13:26:01Leonardofreuasetmessages: + msg397622
2021-07-16 11:27:07iritkatrielsetstatus: open -> closed

nosy: + iritkatriel
messages: + msg397614

resolution: not a bug
stage: resolved
2021-07-15 20:44:29Leonardofreuasetmessages: + msg397582
2021-07-15 20:40:33Leonardofreuasettitle: Move test_futures files* into a subdirectory of Lib/test -> Move test_futures files*.py into a subdirectory of Lib/test
2021-07-15 20:40:23Leonardofreuasettype: enhancement
components: + Library (Lib), Tests
versions: + Python 3.11
2021-07-15 20:39:48Leonardofreuacreate