classification
Title: Version is duplicated in name of app in list of installed apps
Type: behavior Stage: resolved
Components: Windows Versions: Python 3.9
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: paul.moore, rakleed, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2021-07-14 10:51 by rakleed, last changed 2021-07-21 17:08 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
2021-07-14 13-49-41 Settings.png rakleed, 2021-07-14 10:51
2021-07-14 13-50-19 Programs and Features.png rakleed, 2021-07-14 10:52
Apps and Features.png paul.moore, 2021-07-16 09:28
Messages (7)
msg397474 - (view) Author: Pavel Moiseenko (rakleed) Date: 2021-07-14 10:51
The version of the app is duplicated in the name of the app in the list of installed apps in "Settings - Apps - Apps & features" and "Control Panel - Programs - Programs and Features" in the version for Windows. Please remove the version number from the app name, as the version number is displayed next to the name in a separate field.
msg397490 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-07-14 15:55
Apart from the duplication, is there some reason why this is a problem?

The name is used in a number of other places where the version number is very helpful. I'm not sure we can separate the variables in WiX.
msg397583 - (view) Author: Pavel Moiseenko (rakleed) Date: 2021-07-15 21:12
This does not cause any problems in the operation of the app, but visually it looks strange. Most other apps don't indicate the version of the app in the name of the app, but just indicate it in a specially made field for this. Therefore, it would be nice if your app followed this behavior.

Perhaps these links will also be helpful: https://docs.microsoft.com/en-us/windows/win32/msi/uninstall-registry-key, https://stackoverflow.com/questions/26156405/how-to-change-add-remove-program-name-using-wix-installer

And can you tell me where the WiX config file is?
msg397602 - (view) Author: Paul Moore (paul.moore) * (Python committer) Date: 2021-07-16 07:37
In "Apps and Features" on Windows 10, the application name is shown by default but not the version. I have 3 different versions of Python installed on my PC and if they all reported as "Python" it would be a lot harder to manage them (I'd have to click on each one to check the version before I knew which one to select)

-1 on removing the version from the application name.
msg397605 - (view) Author: Pavel Moiseenko (rakleed) Date: 2021-07-16 09:18
@paul.moore, but you don't need to open additional menus in the control panel to see the version of the app.
msg397607 - (view) Author: Paul Moore (paul.moore) * (Python committer) Date: 2021-07-16 09:28
See the attached screenshot. Only the app name is visible by default.

I see no benefit to the change and a definite usability degradation for people like me with multiple Python versions.
msg397954 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2021-07-21 17:08
Agreed with Paul, it's more useful than confusing to have the version in the name.
History
Date User Action Args
2021-07-21 17:08:05zach.waresetstatus: open -> closed
resolution: not a bug
messages: + msg397954

stage: resolved
2021-07-16 09:28:35paul.mooresetfiles: + Apps and Features.png

messages: + msg397607
2021-07-16 09:18:03rakleedsetmessages: + msg397605
2021-07-16 07:37:49paul.mooresetmessages: + msg397602
2021-07-15 21:12:06rakleedsetmessages: + msg397583
2021-07-14 15:55:34steve.dowersetmessages: + msg397490
2021-07-14 10:52:17rakleedsetfiles: + 2021-07-14 13-50-19 Programs and Features.png
2021-07-14 10:51:23rakleedcreate