classification
Title: Operand coercion breaks MappingProxyType encapsulation
Type: behavior Stage: resolved
Components: Versions: Python 3.11
process
Status: closed Resolution: duplicate
Dependencies: Superseder: There is a way to access an underlying mapping in MappingProxyType
View: 43838
Assigned To: Nosy List: ncoghlan, serhiy.storchaka
Priority: normal Keywords:

Created on 2021-07-10 06:55 by ncoghlan, last changed 2021-07-10 10:00 by serhiy.storchaka. This issue is now closed.

Messages (2)
msg397242 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2021-07-10 06:55
The fast locals proxy implementation for PEP 558 used the existing MappingProxyType implementation as a starting point.

This meant I noticed the following code in the mapping proxy comparison implementation:

======
static PyObject *
mappingproxy_richcompare(mappingproxyobject *v, PyObject *w, int op)
{
    return PyObject_RichCompare(v->mapping, w, op);
}
======

Seeing that code lead to trying the following experiment:

==========
>>> from types import MappingProxyType
>>> d = {}
>>> proxy = MappingProxyType(d)
>>> class Sneaky:
...     def __eq__(self, other):
...         if other is d:
...             raise RuntimeError("Broke encapsulation")
... 
>>> proxy == Sneaky()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "<stdin>", line 4, in __eq__
RuntimeError: Broke encapsulation
==========

The new `__or__` implementation has a corresponding loophole:

========
>>> class SneakyOr:
...     def __or__(self, other):
...         if other is d:
...             raise RuntimeError("Broke encapsulation")
...     def __ror__(self, other):
...         return self.__or__(other)
... 
>>> proxy | SneakyOr()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "<stdin>", line 6, in __ror__
  File "<stdin>", line 4, in __or__
RuntimeError: Broke encapsulation
========

Delegating these operations to the underlying mapping via the abstract operation layer means that the underlying mapping gets exposed to the operand coercion machinery and can hence be accessed by the other operand.
msg397243 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2021-07-10 10:00
It is a duplicate of issue43838.
History
Date User Action Args
2021-07-10 10:00:37serhiy.storchakasetstatus: open -> closed

superseder: There is a way to access an underlying mapping in MappingProxyType

nosy: + serhiy.storchaka
messages: + msg397243
resolution: duplicate
stage: needs patch -> resolved
2021-07-10 06:55:40ncoghlancreate