classification
Title: Organize some data files in the Lib/test directory
Type: enhancement Stage: resolved
Components: Tests Versions: Python 3.11
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Leonardofreua, rhettinger, thatiparthy
Priority: normal Keywords:

Created on 2021-07-06 21:23 by Leonardofreua, last changed 2021-07-10 00:36 by rhettinger. This issue is now closed.

Messages (3)
msg397056 - (view) Author: Leonardo Freua (Leonardofreua) * Date: 2021-07-06 21:23
I noticed that some data files (used to perform some specific tests) are not organized in specific directories of their categories. Some files that I found are audiotest.au, badcert.pem, badkey.pem, cfgparser.1, cfgparser.2, etc (some are even .py files).

I'm working on an organization so they don't get mixed up with the test files, but how the rest of the data files are organized (audiodata, capath, cjkencodings, etc.).
msg397178 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2021-07-09 01:21
In practice, this hasn't been an issue.  I recommend leaving it alone. Adding more directories is also a nuisance and doesn't really make anyone's life better.
msg397186 - (view) Author: Srinivas Reddy Thatiparthy(శ్రీనివాస్ రెడ్డి తాటిపర్తి) (thatiparthy) * Date: 2021-07-09 05:19
+1 for Raymond's comment.
History
Date User Action Args
2021-07-10 00:36:38rhettingersetstatus: open -> closed
resolution: not a bug
2021-07-09 17:19:51Leonardofreuasetstatus: closed -> open
2021-07-09 15:10:56Leonardofreuasetstatus: open -> closed
type: enhancement
stage: resolved
2021-07-09 05:19:21thatiparthysetnosy: + thatiparthy
messages: + msg397186
2021-07-09 01:21:27rhettingersetnosy: + rhettinger
messages: + msg397178
2021-07-06 21:23:51Leonardofreuacreate