This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: Substraction: unprecise result
Type: behavior Stage: resolved
Components: Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: eric.smith, user_0101
Priority: normal Keywords:

Created on 2021-07-02 12:52 by user_0101, last changed 2022-04-11 14:59 by admin. This issue is now closed.

Messages (2)
msg396862 - (view) Author: user_0101 (user_0101) Date: 2021-07-02 12:52
```
>>> 2.11-1.56
0.5499999999999998
```
msg396863 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2021-07-02 12:57
This is not a bug, but expected floating point behavior. See https://docs.python.org/3/tutorial/floatingpoint.html
History
Date User Action Args
2022-04-11 14:59:47adminsetgithub: 88717
2021-07-02 12:57:30eric.smithsetstatus: open -> closed

type: behavior

nosy: + eric.smith
messages: + msg396863
resolution: not a bug
stage: resolved
2021-07-02 12:52:25user_0101create