classification
Title: MSI installer shows error message if "Compile .py files to bytecode" option is selected
Type: behavior Stage: resolved
Components: Installation Versions: Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: Aaron.Thomas, BreamoreBoy, loewis, steve.dower, suraj, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2008-11-28 15:23 by suraj, last changed 2018-09-03 21:55 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
SetupError.JPG suraj, 2008-11-28 15:23 Installer error dialog
Messages (10)
msg76537 - (view) Author: Suraj Barkale (suraj) Date: 2008-11-28 15:23
If the option to "Compile .py files to bytecode after installation" is
selected during installation (by clicking on "Advanced" button on
"Customize" dialog), installer shows the attached dialog. There seems to
be no problem after installation is finished. I have tested this on
Vista Ultimate SP1 32 bit.
msg103241 - (view) Author: Aaron Thomas (Aaron.Thomas) Date: 2010-04-15 18:15
I can verify this will all versions of Windows 7, and the versions of python 32 and 64 bit. I install this at my work to many machines, and every one of them crashes when trying to 'compile py scripts to bytecode' during install.  I have to left click the setup file after installation (installation fails), and choose 'install' in the windows context menu, then choose 'repair python' for the installation to complete 'successfully'.
msg112760 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2010-08-04 05:00
Can either of you check 2.7/3.1 or 2a?
msg112762 - (view) Author: Aaron Thomas (Aaron.Thomas) Date: 2010-08-04 05:03
3.1, yes, same problem
2.7, I'll check
what's 2a?

Aaron

On Aug 3, 2010 10:00 PM, "Terry J. Reedy" <report@bugs.python.org> wrote:

Terry J. Reedy <tjreedy@udel.edu> added the comment:

Can either of you check 2.7/3.1 or 2a?

----------
nosy: +tjreedy
versions: +Python 2.7 -Python 2.5, Python 2.6, Python 3.0

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue4453>
_______________________________________
msg112764 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2010-08-04 05:14
python 3.2a1, out 2 days ago. Unless Martin says otherwise, I will assume it is the same.
msg112770 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-08-04 08:23
This bug comes and goes. It means that compileall failed, and it will fail when there are files that it can't compile. People keep adding such files to the tree, and I keep excluding them from compileall then at some release.

The original report may be a duplicate of issue6716, which was fixed in r78991 and r78994.
msg112828 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2010-08-04 16:07
I marked this for the version Aaron verified.

It seems to me that the following switch is backwards:

                    if quiet:
                        print('*** Error compiling', fullname, '...')
                    else:
                        print('*** ', end='')

Quiet True should print less, not more.
msg112836 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-08-04 17:37
compileall.py is correct as it stands. In verbose mode, it prints out every file it is compiling, a few lines above:

                if not quiet:
                    print('Compiling', fullname, '...')

In quiet mode, it only prints errors.
msg222816 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-07-12 00:47
I don't recall ever seeing this problem.
msg324541 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2018-09-03 21:55
According to Martin in msg112770, this was due to files that could not be compiled.  There shouldn't be any more of those added to 2.7 (which is the last version receiving binary releases using this installer scheme), so I'm closing the issue.
History
Date User Action Args
2018-09-03 21:55:40zach.waresetstatus: open -> closed
versions: + Python 2.7, - Python 3.4, Python 3.5
messages: + msg324541

resolution: out of date
stage: resolved
2014-07-12 01:36:18zach.waresetfiles: - unnamed
2014-07-12 00:47:22BreamoreBoysetnosy: + BreamoreBoy, zach.ware, steve.dower

messages: + msg222816
versions: + Python 3.4, Python 3.5, - Python 3.1
2010-08-04 17:37:57loewissetmessages: + msg112836
2010-08-04 16:07:50terry.reedysetmessages: + msg112828
versions: + Python 3.1, - Python 2.7
2010-08-04 08:23:06loewissetmessages: + msg112770
2010-08-04 07:50:12tim.goldensetnosy: + tim.golden
2010-08-04 05:14:34terry.reedysetnosy: + loewis
messages: + msg112764
2010-08-04 05:03:54Aaron.Thomassetfiles: + unnamed

messages: + msg112762
2010-08-04 05:00:20terry.reedysetnosy: + terry.reedy

messages: + msg112760
versions: + Python 2.7, - Python 2.6, Python 2.5, Python 3.0
2010-04-15 18:15:24Aaron.Thomassetnosy: + Aaron.Thomas

messages: + msg103241
versions: + Python 2.6, Python 2.5
2008-11-28 15:23:17surajcreate