classification
Title: 3.11 docs.python.org in Polish not English?
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.11, Python 3.10
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: mdk Nosy List: cryvate, docs@python, josh.r, mdk, samuelmarks
Priority: normal Keywords:

Created on 2021-06-21 06:52 by samuelmarks, last changed 2021-06-27 13:03 by mdk. This issue is now closed.

Files
File name Uploaded Description Edit
Screen Shot 2021-06-21 at 4.49.27 pm.png samuelmarks, 2021-06-21 06:52
Messages (11)
msg396207 - (view) Author: Samuel Marks (samuelmarks) * Date: 2021-06-21 06:52
It's been too long since my family have been Polish!

(see screenshot of https://docs.python.org/3.11/library/parser.html )

My computer is only configured for English. Running Firefox 90.0b9 (64-bit) on macOS 11.4 (20F71).
msg396212 - (view) Author: Henk-Jaap Wagenaar (cryvate) * Date: 2021-06-21 08:03
I can confirm it looks the same to me, and I have never said Polish in my browser et cetera, so I assume this is the same for everyone.
msg396213 - (view) Author: Henk-Jaap Wagenaar (cryvate) * Date: 2021-06-21 08:27
It seems to affect 3.10 as well and other languages (French seems to show a variety fo languages)
msg396256 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2021-06-21 15:43
The bug here is that https://docs.python.org/3.11/library/parser.html is visible at all, given that the parser module no longer exists in 3.10 or 3.11.

@Samuel: Do you see this on any other documentation nodes, or just on parser.html? I can reproduce the confusion on parser.html, but I don't see it anywhere else.
msg396258 - (view) Author: Henk-Jaap Wagenaar (cryvate) * Date: 2021-06-21 15:45
@Mark, I don't know about Samuel, but when I tried, I could get the bug with other languages, but not on other pages (which seems to agree with your point of reasoning).
msg396263 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2021-06-21 16:02
Hi all! Thanks for reporting! I'm taking a look at it.
msg396265 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2021-06-21 16:09
I added a git clean in docsbuild scripts to switch from one version to another:

https://github.com/python/docsbuild-scripts/commit/1397a8dbe4c73744757ad24764baeb393842f30b

It should be enough to correctly start fresh from one lang to another and from one version to another.

Let's check next time the cron runs (daily) if it's fixed.
msg396450 - (view) Author: Josh Rosenberg (josh.r) * (Python triager) Date: 2021-06-24 03:02
I just visited the link, and it's now *mostly* English, but with random bits of Korean in it (mostly in links and section headers).

The first warning block for instance begins:

경고: The parser module is deprecated...

Then a few paragraphs later I'm told:

For full information on the language syntax, refer to 파이썬 언어 레퍼런스.

where the Korean is a hyperlink to the Python Language Reference. Very strange.
msg396455 - (view) Author: Samuel Marks (samuelmarks) * Date: 2021-06-24 06:57
Yep exactly like my screenshot but now the Polish has turned Korean… my family was never Korean!
msg396578 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2021-06-27 12:55
Thanks all for reporting and following on the issue.

The fix on docsbuild script worked as expected and the page now 404 as expected as it does no logner exists in 3.11:

https://docs.python.org/3.11/library/parser.html
msg396579 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2021-06-27 13:03
> My computer is only configured for English. Running Firefox 90.0b9 (64-bit) on macOS 11.4 (20F71).

To add to this, it had nothing to do with your setup, the file was just lying here on the server due to the previous build happening on the same hierarchy.

That's why adding a git clean fixed it.

Next time you find a similar issue you can easily test if it's dependent on your setup or not by trying a curl in command-line:

$ curl https://docs.python.org/3.11/library/parser.html

curl sends very simple requests, without looking at your locale preferences, like:

    GET /3.11/library/parser.html HTTP/1.1
    Host: docs.python.org
    User-Agent: curl/7.74.0
    Accept: */*

so it permit to easily disambiguate if it's tied to your browser or not.
History
Date User Action Args
2021-06-27 13:03:15mdksetmessages: + msg396579
2021-06-27 12:55:06mdksetstatus: open -> closed
resolution: fixed
messages: + msg396578

stage: resolved
2021-06-24 06:57:34samuelmarkssetmessages: + msg396455
2021-06-24 03:02:24josh.rsetnosy: + josh.r
messages: + msg396450
2021-06-23 16:35:35mark.dickinsonsetnosy: - mark.dickinson
2021-06-21 16:09:35mdksetmessages: + msg396265
2021-06-21 16:02:02mdksetassignee: docs@python -> mdk
messages: + msg396263
2021-06-21 15:45:50cryvatesetmessages: + msg396258
2021-06-21 15:43:22mark.dickinsonsetnosy: + mark.dickinson
messages: + msg396256
2021-06-21 15:30:21vstinnersetnosy: + mdk
2021-06-21 08:27:12cryvatesetmessages: + msg396213
versions: + Python 3.10
2021-06-21 08:03:42cryvatesetnosy: + cryvate
messages: + msg396212
2021-06-21 06:52:35samuelmarkscreate