classification
Title: Add Linked Linked module
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.11
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: AjithRamachandran, Dennis Sweeney, Jelle Zijlstra
Priority: normal Keywords:

Created on 2021-06-11 15:18 by AjithRamachandran, last changed 2021-06-11 17:23 by Jelle Zijlstra. This issue is now closed.

Messages (3)
msg395640 - (view) Author: Ajith Ramachandran (AjithRamachandran) * Date: 2021-06-11 15:18
There is a module present for queue which can also be used for a stack like LIFO structure. But there is none for linked list.
msg395650 - (view) Author: Dennis Sweeney (Dennis Sweeney) * (Python triager) Date: 2021-06-11 17:14
This issue is probably a duplicate of https://bugs.python.org/issue42575 .

In almost all use cases, a linked list can be replaced by a collections.deque, which already uses a double linked list of blocks internally. Is there something you need a linked list to do that you can't do already with a deque?
msg395652 - (view) Author: Jelle Zijlstra (Jelle Zijlstra) * (Python triager) Date: 2021-06-11 17:23
Closing as a duplicate of issue42575. Adding a linked list data structure to Python is in any case probably better discussed on the python-ideas mailing list and then in a PEP.
History
Date User Action Args
2021-06-11 17:23:43Jelle Zijlstrasetstatus: open -> closed

nosy: + Jelle Zijlstra
messages: + msg395652

resolution: duplicate
stage: resolved
2021-06-11 17:14:41Dennis Sweeneysetnosy: + Dennis Sweeney
messages: + msg395650
2021-06-11 15:18:53AjithRamachandrancreate