classification
Title: Sphinx latex writer crashes when encountering deep section levels
Type: behavior Stage:
Components: Documentation tools (Sphinx) Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: georg.brandl, schuppenies
Priority: normal Keywords:

Created on 2008-11-26 09:42 by schuppenies, last changed 2008-11-27 17:07 by georg.brandl. This issue is now closed.

Messages (2)
msg76456 - (view) Author: Robert Schuppenies (schuppenies) * (Python committer) Date: 2008-11-26 09:42
The Sphinx latex writer crashes if a documentation has more than 7
levels in a section hierarchy. The LaTeXTranslator class defines 7
section names, each corresponding to a level. If a deeper level is
encountered, no appropriate section name can be found:

File "[..]/svn/doctools/sphinx/latexwriter.py", line 348,  in visit_title
     print "self.sectionnames", self.sectionnames[self.sectionlevel]
IndexError: list index out of range
msg76505 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-11-27 17:07
Please submit Sphinx bugs in its own tracker:
http://bitbucket.org/birkenfeld/sphinx/issues

(Yes, I know there was still a Sphinx component -- I've removed that now.)
History
Date User Action Args
2008-11-27 17:07:55georg.brandlsetstatus: open -> closed
resolution: not a bug
messages: + msg76505
2008-11-26 09:42:14schuppeniescreate